summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2020-10-10 09:52:46 -0400
committergraysky2020-10-10 09:52:46 -0400
commita7f829ae794d03c46b13541f1fac2a2f595431b7 (patch)
treee787ed4b5b620db4b793634f2166394831746f75
parent1d0488bbe35f1417377f98f8ae96de3e33ef92df (diff)
downloadaur-a7f829ae794d03c46b13541f1fac2a2f595431b7.tar.gz
Update to 1.107-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--readme.install15
3 files changed, 31 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e3ccba1488..936e2ba4491 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = kodi-standalone-service
pkgdesc = Systemd service to run kodi in stand-alone mode without a DE
- pkgver = 1.106
+ pkgver = 1.107
pkgrel = 1
url = https://github.com/graysky2/kodi-standalone-service
install = readme.install
arch = x86_64
- license = GPL
- source = kodi-standalone-service-v1.106.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.106.tar.gz
- b2sums = 4fb670b66d037e8fa718582887dd2588e3756da603c7d19b9ece03392327e3b36958b6b0b20a985b013eac2be26c61862980141d44187c3c6fbd79adb14c3a28
+ license = MIT
+ source = kodi-standalone-service-v1.107.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.107.tar.gz
+ b2sums = e28940bb2a19e55e3ff0115f45416235532272473a7f6e07d96f3d8b6162cbf67581347ea11239e9e98b6ce58170c8df6a8a12ad9bcc025f3bb39b87a3dc04e8
-pkgname = kodi-standalone-service
- depends = kodi
+pkgname = kodi-standalone-x11-service
+ depends = kodi-x11
depends = polkit
depends = xorg-server
depends = xorg-xinit
+ conflicts = kodi-standalone-service
+ replaces = kodi-standalone-service
pkgname = kodi-standalone-gbm-service
depends = kodi-gbm
diff --git a/PKGBUILD b/PKGBUILD
index 0f21d961ca7..01859e39efd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
pkgbase=kodi-standalone-service
-pkgname=(kodi-standalone-service kodi-standalone-gbm-service kodi-standalone-wayland-service)
-pkgver=1.106
+pkgname=(kodi-standalone-x11-service kodi-standalone-gbm-service kodi-standalone-wayland-service)
+pkgver=1.107
pkgrel=1
pkgdesc="Systemd service to run kodi in stand-alone mode without a DE"
# Do NOT attempt to use this package on Arch ARM! This is only for x86_64.
# You have been warned.
arch=('x86_64')
url="https://github.com/graysky2/kodi-standalone-service"
-license=('GPL')
+license=('MIT')
install=readme.install
source=("$pkgbase-v$pkgver.tar.gz::https://github.com/graysky2/$pkgbase/archive/v$pkgver.tar.gz")
-b2sums=('4fb670b66d037e8fa718582887dd2588e3756da603c7d19b9ece03392327e3b36958b6b0b20a985b013eac2be26c61862980141d44187c3c6fbd79adb14c3a28')
+b2sums=('e28940bb2a19e55e3ff0115f45416235532272473a7f6e07d96f3d8b6162cbf67581347ea11239e9e98b6ce58170c8df6a8a12ad9bcc025f3bb39b87a3dc04e8')
-package_kodi-standalone-service() {
- depends=('kodi' 'polkit' 'xorg-server' 'xorg-xinit')
+package_kodi-standalone-x11-service() {
+ replaces=('kodi-standalone-service')
+ conflicts=('kodi-standalone-service')
+ depends=('kodi-x11' 'polkit' 'xorg-server' 'xorg-xinit')
cd "$pkgbase-$pkgver"
- install -Dm644 init/kodi.service "$pkgdir/usr/lib/systemd/system/kodi.service"
- install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi.conf"
- install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi.conf"
+ install -Dm644 init/kodi-x11.service "$pkgdir/usr/lib/systemd/system/kodi-x11.service"
+ install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi-x11.conf"
+ install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-x11.conf"
}
package_kodi-standalone-gbm-service() {
diff --git a/readme.install b/readme.install
index c2fc9539243..79460171892 100644
--- a/readme.install
+++ b/readme.install
@@ -1,9 +1,18 @@
post_remove() {
- echo "==> Optionally remove /var/lib/kodi/"
+ echo "--> Optionally remove /var/lib/kodi/"
}
post_install() {
- echo "==> Optionally create /etc/conf.d/kodi-standalone if you need to pass"
- echo "==> any environment variables to the service"
+ echo "--> Optionally create /etc/conf.d/kodi-standalone if you need to pass"
+ echo "--> any environment variables to the service"
+
+ if [[ -L /etc/systemd/system/graphical.target.wants/kodi.service ]]; then
+ echo '-->'
+ echo '--> kodi.service is now kodi-x11.service'
+ echo '--> you must disable the old one and enable the new one'
+ fi
+}
+
+pre_upgrade() {
}
# vim:set ts=2 sw=2 et: