summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2018-10-13 17:38:36 +0200
committerJonas Heinrich2018-10-13 17:38:36 +0200
commit6e90ae24ec96b3643b1a28042b6dc5810c5f68c0 (patch)
tree87b96ff38e4f5457ce2daf37a3914b763fd6b8b3
parent8bd49b28da125035c0904af9f7bfb36685f195d1 (diff)
downloadaur-6e90ae24ec96b3643b1a28042b6dc5810c5f68c0.tar.gz
added yarn install to build instructions
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--koel.install1
3 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5571a1dc31d8..413eaaa1d4b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 13 15:16:49 UTC 2018
+# Sat Oct 13 15:38:21 UTC 2018
pkgbase = koel
pkgdesc = A personal music streaming server that works.
pkgver = 3.7.2
- pkgrel = 1
+ pkgrel = 2
url = http://koel.phanan.net/
install = koel.install
arch = any
@@ -11,6 +11,7 @@ pkgbase = koel
makedepends = php-composer
depends = php
depends = python3
+ depends = yarn
optdepends = php-pgsql: to use the PostGreSQL database backend
optdepends = php-sqlsrv: to use the Microsoft SQL database backend
optdepends = mariadb: to use the MySQL database backend
diff --git a/PKGBUILD b/PKGBUILD
index d433bf4487d6..2dda139078f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=koel
pkgver=3.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="A personal music streaming server that works."
arch=('any')
url="http://koel.phanan.net/"
license=('MIT')
-depends=('php' 'python3')
+depends=('php' 'python3' 'yarn')
makedepends=('php-composer')
optdepends=('php-pgsql: to use the PostGreSQL database backend'
'php-sqlsrv: to use the Microsoft SQL database backend'
@@ -24,6 +24,7 @@ sha512sums=('b3ae40db2839f9b411716428203f595ca685ea2d87599c0704fb271446126c998a9
build() {
cd "$pkgname-$pkgver"
COMPOSER_CACHE_DIR="${srcdir/composer}" composer install
+ yarn install
}
package() {
diff --git a/koel.install b/koel.install
index 5c394e632668..a021e7351b70 100644
--- a/koel.install
+++ b/koel.install
@@ -1,4 +1,5 @@
post_install() {
+ chown -R http:http /usr/share/webapps/koel/storage /usr/share/webapps/koel/public
printf "==> Edit the .env file at /usr/share/webapps/koel with your chosen\n==> database settings and add the details for your admin account\n==> then run 'php composer koel:init'.\n==> Remove your admin details afterward.\n==> Use 'php composer koel:sync' to update your library from the\n==> command line."
}