summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartinVonReich2024-04-01 18:21:39 +0200
committerMartinVonReich2024-04-01 18:21:39 +0200
commit3c9b61d4dc5d1fb872ffa7163b62f98b06c2fa1a (patch)
treef5adc4465e64acd27b17d9cfc17b2a63183a4f39
parentd705b504469eb84d479bbcf584c20307d41b86b3 (diff)
downloadaur-3c9b61d4dc5d1fb872ffa7163b62f98b06c2fa1a.tar.gz
Erased redundantly mentioned dependencies in PKGBUILD; KF5/QT5 Libraries can co-exist with KF6/QT6 ones, however, build dependencies require QT5 Toolkit.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35ebf02acbe5..020238b1c6f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = koi
pkgdesc = Scheduled LIGHT/DARK Theme Switching for the KDE Plasma Desktop
pkgver = 0.2.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/baduhai/Koi
arch = x86_64
arch = aarch64
@@ -12,19 +12,9 @@ pkgbase = koi
makedepends = qt5-svg
makedepends = cmake
makedepends = extra-cmake-modules
- depends = gcc-libs
- depends = glibc
depends = plasma-integration
depends = plasma-framework5
- depends = kcoreaddons5
- depends = kconfig5
- depends = kwidgetsaddons5
- depends = kwindowsystem5
- depends = kconfigwidgets5
- depends = kxmlgui5
depends = hicolor-icon-theme
- depends = qt5-base
- optdepends = desktop-file-utils: Command line utilities for working with desktop entries
optdepends = xsettingsd: Apply settings to GTK applications on the fly
source = Koi-0.2.4.tar.gz::https://github.com/baduhai/Koi/archive/refs/tags/0.2.4.tar.gz
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c07abcf48f65..73cd16b27e26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,14 @@
pkgname='koi'
_pkgname='Koi'
pkgver=0.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="Scheduled LIGHT/DARK Theme Switching for the KDE Plasma Desktop"
arch=('x86_64' 'aarch64')
url="https://github.com/baduhai/Koi"
license=('LGPL3')
-depends=('gcc-libs' 'glibc' 'plasma-integration' 'plasma-framework5' 'kcoreaddons5' 'kconfig5'
- 'kwidgetsaddons5' 'kwindowsystem5' 'kconfigwidgets5' 'kxmlgui5' 'hicolor-icon-theme' 'qt5-base')
+depends=('plasma-integration' 'plasma-framework5' 'hicolor-icon-theme')
makedepends=('gcc' 'qt5-base' 'qt5-tools' 'qt5-svg' 'cmake' 'extra-cmake-modules')
-optdepends=('desktop-file-utils: Command line utilities for working with desktop entries'
- 'xsettingsd: Apply settings to GTK applications on the fly')
+optdepends=('xsettingsd: Apply settings to GTK applications on the fly')
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/baduhai/Koi/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('SKIP')
@@ -25,15 +23,11 @@ build() {
-B "${srcdir}/${_pkgname}-${pkgver}/src/build/" \
-DCMAKE_INSTALL_PREFIX=/usr/
- cd "${srcdir}/${_pkgname}-${pkgver}/src/build/"
-
- make all
+ make -C "${srcdir}/${_pkgname}-${pkgver}/src/build/" all
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}/src/build/"
-
- make DESTDIR="${pkgdir}" install all
+ make -C "${srcdir}/${_pkgname}-${pkgver}/src/build/" DESTDIR="${pkgdir}" install
install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/src/koi.desktop" -t "${pkgdir}/usr/share/applications/"
}