summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartinVonReich2023-12-15 18:55:36 +0100
committerMartinVonReich2023-12-15 18:55:36 +0100
commit697304dff8f6e39bb8440e299f935f03916f350b (patch)
tree229327e633a7a68be4056fcbc8eae9c655493c4b
parentaee37a4e2f08ff8bfdcbe4b8e411ee15a35bc5ba (diff)
downloadaur-697304dff8f6e39bb8440e299f935f03916f350b.tar.gz
A small rebuild of PKGBUILD file and its Dependencies, removed `Conflicts: ``koi-git`, added back `Provides: koi` as it should be mentioned only once inside ``koi-git` PKGBUILD and not on both sides . . .
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c487f17b7f6e..1f8a8083bb9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = koi-git
pkgdesc = Scheduled LIGHT/DARK Theme Switching for the KDE Plasma Desktop
pkgver = 0.2.4.r0.geae87d1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/baduhai/Koi
arch = x86_64
arch = aarch64
license = LGPL3
makedepends = git
- makedepends = glibc
+ makedepends = gcc
makedepends = qt5-base
makedepends = qt5-tools
makedepends = qt5-svg
makedepends = cmake
makedepends = extra-cmake-modules
- depends = plasma-desktop
+ depends = gcc-libs
+ depends = glibc
depends = plasma-integration
depends = plasma-framework5
depends = kcoreaddons5
@@ -22,11 +23,12 @@ pkgbase = koi-git
depends = kwindowsystem5
depends = kconfigwidgets5
depends = kxmlgui5
- depends = kpackage5
depends = hicolor-icon-theme
+ depends = qt5-base
+ optdepends = desktop-file-utils: Command line utilities for working with desktop entries
optdepends = xsettingsd: Apply settings to GTK applications on the fly
+ provides = koi
conflicts = koi
- options = !strip
source = Koi-0.2.4.r0.geae87d1::git+https://github.com/baduhai/Koi.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 71ff9052e598..02457bcdcd45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,20 @@ pkgname='koi-git'
_pkgname='koi'
__pkgname='Koi'
pkgver=0.2.4.r0.geae87d1
-pkgrel=1
+pkgrel=2
pkgdesc="Scheduled LIGHT/DARK Theme Switching for the KDE Plasma Desktop"
arch=('x86_64' 'aarch64')
url="https://github.com/baduhai/Koi"
license=('LGPL3')
-depends=('plasma-desktop' 'plasma-integration' 'plasma-framework5' 'kcoreaddons5' 'kconfig5'
- 'kwidgetsaddons5' 'kwindowsystem5' 'kconfigwidgets5' 'kxmlgui5' 'kpackage5' 'hicolor-icon-theme')
-makedepends=('git' 'glibc' 'qt5-base' 'qt5-tools' 'qt5-svg' 'cmake' 'extra-cmake-modules')
-optdepends=('xsettingsd: Apply settings to GTK applications on the fly')
+depends=('gcc-libs' 'glibc' 'plasma-integration' 'plasma-framework5' 'kcoreaddons5' 'kconfig5'
+ 'kwidgetsaddons5' 'kwindowsystem5' 'kconfigwidgets5' 'kxmlgui5' 'hicolor-icon-theme' 'qt5-base')
+makedepends=('git' 'gcc' 'qt5-base' 'qt5-tools' 'qt5-svg' 'cmake' 'extra-cmake-modules')
+optdepends=('desktop-file-utils: Command line utilities for working with desktop entries'
+ 'xsettingsd: Apply settings to GTK applications on the fly')
+provides=('koi')
conflicts=('koi')
source=("${__pkgname}-${pkgver}::git+https://github.com/baduhai/Koi.git")
sha256sums=('SKIP')
-options=('!strip')
-
pkgver() {
cd "${srcdir}/${__pkgname}-${pkgver}"