summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor K. H2018-07-16 10:31:06 +0200
committerThor K. H2018-07-16 10:31:06 +0200
commita850bd30e9a51f133d544d0568d4a6a93be46ba0 (patch)
tree581fcde05796bf25f9e3d76d4a51105fad464eb4
parent3952fdbd89c9334bdb198ae51c776a03940e784b (diff)
downloadaur-koku-xinput-wine-git.tar.gz
Updated version; added warning, but no practical change
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df12e163ac47..3d9adfe9f2e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Mon Nov 13 15:35:48 UTC 2017
+# Mon Jul 16 08:30:51 UTC 2018
pkgbase = koku-xinput-wine-git
pkgdesc = Adds xinput support to Wine without modifying the source binaries of Wine.
- pkgver = 1.2.1.r0.g11e7f4a
+ pkgver = 1.2.3.r0.gd976325
pkgrel = 1
url = https://www.github.com/KoKuToru/koku-xinput-wine
arch = i686
arch = x86_64
- license = GPL3
+ license = BSD
makedepends = git
makedepends = cmake
makedepends = wine
diff --git a/PKGBUILD b/PKGBUILD
index b266dd9e92db..b8ec36beaeca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Thor M. K. Høgås <thor alfakrøll roht dott no>
+# Maintainer : Thor M. K. Høgås <thor alfakrøll roht dott no>
pkgname=koku-xinput-wine-git
-pkgver=1.2.1.r0.g11e7f4a
+pkgver=1.2.3.r0.gd976325
pkgrel=1
_srcname=koku-xinput-wine
pkgdesc="Adds xinput support to Wine without modifying the source binaries of Wine."
arch=('i686' 'x86_64')
url="https://www.github.com/KoKuToru/koku-xinput-wine"
-license=('custom:BSD2')
+license=('BSD')
provides=("${pkgname[0]%-git}")
conflicts=("${pkgname[0]%-git}")
@@ -20,22 +20,24 @@ md5sums=('SKIP')
pkgver() {
- cd "${_srcname}"
+ cd "${_srcname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${_srcname}"
- cmake .
- make
+ cmake -DCMAKE_BUILD_TYPE=Release .
+ make
}
package() {
cd "${srcdir}/${_srcname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/BSD2"
+
if [ "$CARCH" == "x86_64" ]; then
install -Dm755 koku-xinput-wine.so koku-xinput-wine64.so -t "${pkgdir}/usr/lib32/"
else
+ warning "i686 is not supported, although it may work, in this package."
install -Dm755 koku-xinput-wine.so -t "${pkgdir}/usr/lib/"
fi
}