summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2024-03-26 04:42:54 +0000
committerJoão Figueiredo2024-03-26 04:42:54 +0000
commitf1f1e8c092eff606a60d35e68541fb5e5faece0f (patch)
tree5cf08ca02ddcb7bb1ebf7f86b26debb7dfdd7fd9
parentfbf95a39220e59279b6ef1c17846e4ebd64e012a (diff)
downloadaur-f1f1e8c092eff606a60d35e68541fb5e5faece0f.tar.gz
Merged with official ABS kolourpaint PKGBUILD
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD58
2 files changed, 45 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6d5187f40d3..0306717212a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,31 @@
pkgbase = kolourpaint-git
- pkgdesc = Paint Program. (GIT version)
- pkgver = r2290.75f54996
+ pkgdesc = Paint Program
+ pkgver = 24.04.70_r2667.g24e7731b
pkgrel = 1
- url = http://kde.org/applications/graphics/kolourpaint
+ url = https://apps.kde.org/kolourpaint/
arch = x86_64
- license = GPL
- license = LGPL
- license = FDL
- makedepends = extra-cmake-modules
- makedepends = kdoctools
+ license = GPL-2.0-or-later
+ license = LGPL-2.0-or-later
makedepends = git
- makedepends = python
- makedepends = kdesignerplugin
- depends = kxmlgui
- depends = kio
- depends = libksane
+ makedepends = extra-cmake-modules-git
+ makedepends = kdoctools5
+ depends = gcc-libs
+ depends = glibc
+ depends = kconfig5
+ depends = kconfigwidgets5
+ depends = kcoreaddons5
+ depends = kguiaddons5
+ depends = ki18n5
+ depends = kio5
+ depends = kjobwidgets5
+ depends = ktextwidgets5
+ depends = kwidgetsaddons5
+ depends = kxmlgui5
+ depends = libksane-git
+ depends = qt5-base
provides = kolourpaint
- conflicts = kdegraphics-kolourpaint
conflicts = kolourpaint
- source = git://anongit.kde.org/kolourpaint
- sha1sums = SKIP
+ source = git+https://github.com/KDE/kolourpaint.git
+ sha256sums = SKIP
pkgname = kolourpaint-git
-
diff --git a/PKGBUILD b/PKGBUILD
index edddd2e19803..5550d4ed4ea6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,36 @@
+# Merged with official ABS kolourpaint PKGBUILD by João, 2024/03/26 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
-# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+# Contributor: Martin Sandsmark <martin.sandsmark@kde.org>
pkgname=kolourpaint-git
-pkgver=r2305.dddf80a5
+pkgver=24.04.70_r2667.g24e7731b
pkgrel=1
-pkgdesc="Paint Program. (GIT version)"
-url='http://kde.org/applications/graphics/kolourpaint'
-arch=('x86_64')
-license=('GPL' 'LGPL' 'FDL')
-depends=('kxmlgui'
- 'kio'
- 'libksane'
- )
-makedepends=('extra-cmake-modules'
- 'kdoctools'
- 'git'
- 'python'
- 'kdesignerplugin'
- )
-conflicts=('kdegraphics-kolourpaint'
- 'kolourpaint'
- )
-provides=('kolourpaint')
-source=('git+https://anongit.kde.org/kolourpaint')
-sha1sums=('SKIP')
+pkgdesc='Paint Program'
+url='https://apps.kde.org/kolourpaint/'
+arch=($CARCH)
+license=(GPL-2.0-or-later LGPL-2.0-or-later)
+depends=(gcc-libs glibc kconfig5 kconfigwidgets5 kcoreaddons5 kguiaddons5 ki18n5 kio5 kjobwidgets5 ktextwidgets5 kwidgetsaddons5 kxmlgui5 libksane-git qt5-base)
+makedepends=(git extra-cmake-modules-git kdoctools5)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd kolourpaint
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- mkdir -p build
+ cd ${pkgname%-git}
+ _major_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MAJOR' CMakeLists.txt | cut -d '"' -f2)"
+ _minor_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MINOR' CMakeLists.txt | cut -d '"' -f2)"
+ _micro_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MICRO' CMakeLists.txt | cut -d '"' -f2)"
+ echo "${_major_ver}.${_minor_ver}.${_micro_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../kolourpaint \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ cmake -B build -S ${pkgname%-git} \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}