summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValerii Huz2018-10-04 14:41:33 +0300
committerValerii Huz2018-10-04 14:41:33 +0300
commitc232e76c24473b60beff6fdcd94cdfcc7d7b72e4 (patch)
treefc669db9c24c21cc1764ee5056fa073da322bf58
downloadaur-c232e76c24473b60beff6fdcd94cdfcc7d7b72e4.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--COPYING1
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b578959abd72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = komodo-9
+ pkgdesc = Freeware version of the Komodo chess engine (~3310 Elo)
+ pkgver = 9
+ pkgrel = 02
+ url = https://komodochess.com
+ arch = x86_64
+ license = custom
+ conflicts = komodo-engine
+ source = http://komodochess.com/pub/komodo-9.zip
+ source = http://komodochess.com/pub/Komodo3-book.zip
+ source = COPYING
+ sha256sums = 97d0f7c4e5d23f43d3d2cccc6b9bd27cb61fe56b88a57d76fdbefeefad8900ca
+ sha256sums = 3ada9836a4b8a8bdbc362c90bce1b63b9472fc0194e39d9d36119ba102e9e9cd
+ sha256sums = 0d81e7e34a9563047580052052646c5ebb656a39a4575043e0fef6f7704cb18b
+
+pkgname = komodo-9
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..55dd8c98e9db
--- /dev/null
+++ b/COPYING
@@ -0,0 +1 @@
+Komodo is protected by copyright. Komodo, even our freeware versions, can not be redistributed on other websites.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5801bb57792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=komodo-9
+pkgver=9
+pkgrel=02
+_pkgdir=_9dd577
+pkgdesc="Freeware version of the Komodo chess engine (~3310 Elo)"
+arch=(x86_64)
+url=https://komodochess.com
+license=(custom)
+conflicts=(komodo-engine)
+source=(http://komodochess.com/pub/${pkgname%-*}-$pkgver.zip
+ http://komodochess.com/pub/Komodo3-book.zip
+ COPYING)
+sha256sums=(97d0f7c4e5d23f43d3d2cccc6b9bd27cb61fe56b88a57d76fdbefeefad8900ca
+ 3ada9836a4b8a8bdbc362c90bce1b63b9472fc0194e39d9d36119ba102e9e9cd
+ 0d81e7e34a9563047580052052646c5ebb656a39a4575043e0fef6f7704cb18b)
+
+package() {
+ cd ${pkgname%-*}-$pkgver$_pkgdir
+ install -Dm755 Linux/${pkgname%-*}-$pkgver.$pkgrel-linux "$pkgdir"/usr/bin/${pkgname%-*}
+ install -Dm644 ../Book.bin "$pkgdir"/usr/share/$pkgname/book.bin
+ install -Dm644 ../COPYING "$pkgdir"/usr/share/licenses/${pkgname}/COPYING
+ install -dm755 "$pkgdir"/usr/share/doc/${pkgname}/
+ install -m644 *.* "$pkgdir"/usr/share/doc/${pkgname}/
+}