summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValerii Huz2021-04-30 18:41:07 +0300
committerValerii Huz2021-04-30 18:41:41 +0300
commit18dc554d75b879f12e9189a75927ad6466cbe8f2 (patch)
treeb68dc8638a1c17e97bd516d02aabc73d7bfa2423
downloadaur-18dc554d75b879f12e9189a75927ad6466cbe8f2.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--COPYING1
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5972225cf16e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = komodo-free
+ pkgdesc = Freeware version of the Komodo chess engine (~3384 Elo)
+ pkgver = 12
+ pkgrel = 1
+ url = https://komodochess.com
+ arch = x86_64
+ license = custom
+ conflicts = komodo-engine
+ conflicts = komodo-9
+ conflicts = komodo-10
+ conflicts = komodo-11
+ source = http://komodochess.com/pub/komodo-12.zip
+ source = http://komodochess.com/pub/Komodo3-book.zip
+ source = COPYING
+ sha256sums = 3db04ce05b696fa103c8157d2be2c2adf13bf0607d9842fffa8b90104b79a745
+ sha256sums = 3ada9836a4b8a8bdbc362c90bce1b63b9472fc0194e39d9d36119ba102e9e9cd
+ sha256sums = 0d81e7e34a9563047580052052646c5ebb656a39a4575043e0fef6f7704cb18b
+
+pkgname = komodo-free
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..55dd8c98e9db
--- /dev/null
+++ b/COPYING
@@ -0,0 +1 @@
+Komodo is protected by copyright. Komodo, even our freeware versions, can not be redistributed on other websites.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0ea85f01163
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Valerii Huz <ghotrix@gmail.com>
+
+pkgname=komodo-free
+pkgver=12
+pkgrel=1
+pkgminor=1
+_pkgdir=_5a8fc2
+pkgdesc="Freeware version of the Komodo chess engine (~3384 Elo)"
+arch=(x86_64)
+url=https://komodochess.com
+license=(custom)
+conflicts=(komodo-engine komodo-9 komodo-10 komodo-11)
+source=(http://komodochess.com/pub/${pkgname%-*}-$pkgver.zip
+ http://komodochess.com/pub/Komodo3-book.zip
+ COPYING)
+sha256sums=(3db04ce05b696fa103c8157d2be2c2adf13bf0607d9842fffa8b90104b79a745
+ 3ada9836a4b8a8bdbc362c90bce1b63b9472fc0194e39d9d36119ba102e9e9cd
+ 0d81e7e34a9563047580052052646c5ebb656a39a4575043e0fef6f7704cb18b)
+
+package() {
+ cd ${pkgname%-*}-$pkgver.$pkgrel.$pkgminor$_pkgdir
+ install -Dm755 Linux/${pkgname%-*}-$pkgver.$pkgrel.$pkgminor-linux "$pkgdir"/usr/bin/${pkgname%-*}
+ install -Dm644 ../Book.bin "$pkgdir"/usr/share/$pkgname/book.bin
+ install -Dm644 ../COPYING "$pkgdir"/usr/share/licenses/${pkgname}/COPYING
+ install -dm755 "$pkgdir"/usr/share/doc/${pkgname}/
+ install -m644 *.* "$pkgdir"/usr/share/doc/${pkgname}/
+}