summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHusam Bilal2020-08-07 01:08:09 +0300
committerHusam Bilal2020-08-07 01:08:09 +0300
commitf09b4d304f815b93d5e49a405e8a487e3eec70af (patch)
tree9505835949e37b0aed8748a3b40e9279aa199034
downloadaur-f09b4d304f815b93d5e49a405e8a487e3eec70af.tar.gz
Initial
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD17
-rw-r--r--komorebi-bin.install13
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13d79c2ad710
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = komorebi-bin
+ pkgdesc = Parallax backgrounds manager
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://github.com/Komorebi-Fork/komorebi
+ install = komorebi-bin.install
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = glib2>=2.38
+ depends = gtk3>=3.14
+ depends = hicolor-icon-theme
+ depends = libgtop
+ depends = libgee
+ depends = libwnck
+ depends = clutter
+ depends = clutter-gtk
+ depends = clutter-gst
+ depends = webkit2gtk
+ source = https://github.com/Komorebi-Fork/komorebi/releases/download/v2.2.0/komorebi_2.2.0-1_amd64.deb
+ md5sums = b48f5d61e73e8357ba0a7c82d69216ed
+
+pkgname = komorebi-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2898016530cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Husam Bilal <husam212@gmail.com>
+
+pkgname=komorebi-bin
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="Parallax backgrounds manager"
+install=komorebi-bin.install
+arch=("x86_64")
+url="https://github.com/Komorebi-Fork/komorebi"
+license=("GPL")
+depends=("desktop-file-utils" "glib2>=2.38" "gtk3>=3.14" "hicolor-icon-theme" "libgtop" "libgee" "libwnck" "clutter" "clutter-gtk" "clutter-gst" "webkit2gtk")
+md5sums=("b48f5d61e73e8357ba0a7c82d69216ed")
+source=("https://github.com/Komorebi-Fork/komorebi/releases/download/v${pkgver}/komorebi_${pkgver}-1_amd64.deb")
+
+package() {
+ tar xf data.tar.xz -C "${pkgdir}"
+}
diff --git a/komorebi-bin.install b/komorebi-bin.install
new file mode 100644
index 000000000000..b50ffb36e4a2
--- /dev/null
+++ b/komorebi-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}