summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-13 05:11:08 +0300
committerDimitris Kiziridis2020-05-13 05:11:08 +0300
commit1e5423c82c15ee1deda77af8fd94620e2eb3e016 (patch)
tree6587b3cc233a102cb2fa5f2400433ca4f38605f9
parent4749842afaecd609e2a66aedc5c76267b151b8af (diff)
downloadaur-1e5423c82c15ee1deda77af8fd94620e2eb3e016.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d478a79010e5..739d227b473c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,10 @@ pkgbase = kondo-bin
arch = x86_64
license = MIT
provides = kondo
- source = https://github.com/tbillington/kondo/releases/download/v0.3/kondo-x86_64-unknown-linux-gnu.tar.gz
- md5sums = f93cfc72a9f29a7dcf22be5949b208fa
+ source = kondo-bin-0.3.tar.gz::https://github.com/tbillington/kondo/releases/download/v0.3/kondo-x86_64-unknown-linux-gnu.tar.gz
+ source = LICENSE::https://github.com/tbillington/kondo/raw/master/LICENSE
+ sha256sums = e26b8cf06aa4a180852d07c1425c298ac3958c68c6fbdf1faadb9955c835223d
+ sha256sums = 86d6e0473685c1e4e43f0bf291ad7a948035d314ea5986f738a53354f7c059e6
pkgname = kondo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 53f77ba750d0..3b302e5c40cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,13 @@ arch=('x86_64')
url="https://github.com/tbillington/kondo"
license=('MIT')
provides=('kondo')
-source=("${url}/releases/download/v${pkgver}/kondo-x86_64-unknown-linux-gnu.tar.gz")
-md5sums=('f93cfc72a9f29a7dcf22be5949b208fa')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/kondo-x86_64-unknown-linux-gnu.tar.gz"
+ 'LICENSE::https://github.com/tbillington/kondo/raw/master/LICENSE')
+sha256sums=('e26b8cf06aa4a180852d07c1425c298ac3958c68c6fbdf1faadb9955c835223d'
+ '86d6e0473685c1e4e43f0bf291ad7a948035d314ea5986f738a53354f7c059e6')
package() {
install -Dm755 ${srcdir}/kondo "${pkgdir}/usr/bin/kondo"
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file