summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 04:37:24 +0200
committerGoran Nushkov2019-04-06 04:37:24 +0200
commit3c54e8714841dfb43790578c664b3e48e5316737 (patch)
treec2bc693d4d458909e6074f52347c67be4bbf2102
parent2d2f0cfad40a5d597c2f52b3e6d2c2c8b6250126 (diff)
downloadaur-3c54e8714841dfb43790578c664b3e48e5316737.tar.gz
Fixed openresty location
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD42
-rw-r--r--kong-community-edition.install4
3 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73501bdfb250..0a53d6f3f568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,6 @@ pkgbase = kong-community-edition
depends = rsync
options = !strip
options = !emptydirs
- source = https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb
sha512sums = 755e7b1b2cfae427c1dc49ef5bd0dff72b06fda690438f2b831762268313ce53aa14d3f42d2b8f13f6c3cb3643ef1aa74ffde7ccac14b80dd3fc527d3be5204b
pkgname = kong-community-edition
diff --git a/PKGBUILD b/PKGBUILD
index c4590b68b19f..bb1924efb1dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,35 +11,33 @@ groups=('')
depends=('libyaml' 'luajit' 'luarocks' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
+# source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
sha512sums=('755e7b1b2cfae427c1dc49ef5bd0dff72b06fda690438f2b831762268313ce53aa14d3f42d2b8f13f6c3cb3643ef1aa74ffde7ccac14b80dd3fc527d3be5204b')
-package(){
+# package(){
- # Extract package data
- tar xzf data.tar.gz -C "${pkgdir}"
+# # # Extract package data
+# # tar xzf data.tar.gz -C "${pkgdir}"
- # Fix directories structure differencies
- cd "${pkgdir}"
+# # # Fix directories structure differencies
+# # cd "${pkgdir}"
- export PATH=/opt/openresty/bin:$PATH
+# # install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+# # install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
- install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+# # # # Fix openresty location
+# # cd usr/local/bin/
+# # sed -i "s+usr/local/openresty+opt/openresty+g" kong
+# # sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
+# # sed -i "s+usr/local/openresty+opt/openresty+g" lapis
+# # sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
+# # rm luarocks luarocks-5.1 luarocks-admin luarocks-admin-5.1
+# # cd "${pkgdir}"
- # # Fix openresty location
- cd usr/local/bin/
- sed -i "s+usr/local/openresty+opt/openresty+g" kong
- sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
- sed -i "s+usr/local/openresty+opt/openresty+g" lapis
- sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
- rm luarocks luarocks-5.1 luarocks-admin luarocks-admin-5.1
- cd "${pkgdir}"
+# # mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
- mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+# # rsync -a usr/local/* usr; rm -rf usr/local
- rsync -a usr/local/* usr; rm -rf usr/local
+# # cd ..
- cd ..
-
-}
+# }
diff --git a/kong-community-edition.install b/kong-community-edition.install
index 598550c431d3..d88c5545de72 100644
--- a/kong-community-edition.install
+++ b/kong-community-edition.install
@@ -1,8 +1,10 @@
post_install() {
+ echo 'export PATH=/opt/openresty/bin:$PATH' >> ~/.bashrc
+ echo 'export PATH=/uopt/openresty/bin:/opt/openresty/nginx/sbin:$PATH' >> ~/.bashrc
+ source ~/.bashrc
luarocks install kong 1.1.0-0
mkdir -p /etc/kong
mv /usr/lib/luarocks/rocks/kong/1.1.0-0/kong.conf.default /etc/kong/kong.conf.default
-
}
post_upgrade() {