summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 03:25:21 +0200
committerGoran Nushkov2019-04-06 03:25:21 +0200
commit56c8bbd929f36262a967fdc552ccde72f92427be (patch)
tree9724e06d3dc6f0ea9a05a4f4b958a96825829b8c
parent1727b5ffb41b17690a907148fa342cdd9ea0f62d (diff)
downloadaur-56c8bbd929f36262a967fdc552ccde72f92427be.tar.gz
Fixed openresty location
-rw-r--r--PKGBUILD32
1 files changed, 24 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8352a33fa0ef..7266fc87d01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,14 +29,30 @@ package(){
# Fix openresty location
cd usr/local/bin/
- sed -i "s+usr/local+opt+g" kong
- sed -i "s+usr/local+opt+g" json2lua
- sed -i "s+usr/local+opt+g" lapis
- sed -i "s+usr/local+opt+g" lua2json
- sed -i "s+usr/local+opt+g" luarocks
- sed -i "s+usr/local+opt+g" luarocks-5.1
- sed -i "s+usr/local+opt+g" luarocks-admin
- sed -i "s+usr/local+opt+g" luarocks-admin-5.1
+ sed -i "s+usr/local/openresty+opt/openresty+g" kong
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" kong
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" json2lua
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" lapis
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" lapis
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" lua2json
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-5.1
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks-5.1
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-admin
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks-admin
+
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-admin-5.1
+ sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks-admin-5.1
+
cd "${pkgdir}"
mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin