summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 03:58:05 +0200
committerGoran Nushkov2019-04-06 03:58:05 +0200
commitab4782f475354f93dc723339cf1cf61412b5d9bb (patch)
tree0a0d359759a76f21aa570db553b8e4a26a577228
parentb1e416c689b698d7793e81ec9112b315cabf5ce3 (diff)
downloadaur-ab4782f475354f93dc723339cf1cf61412b5d9bb.tar.gz
Fixed openresty location
-rw-r--r--PKGBUILD36
1 files changed, 10 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e7c391a64bf..26b15cb09c3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,32 +28,16 @@ package(){
install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
# # Fix openresty location
- # cd usr/local/bin/
- # sed -i "s+usr/local/openresty+opt/openresty+g" kong
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" kong
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" json2lua
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" lapis
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" lapis
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" lua2json
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" luarocks
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-5.1
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks-5.1
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-admin
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks-admin
-
- # sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-admin-5.1
- # sed -i "s+usr/local/share/lua+usr/share/lua+g" luarocks-admin-5.1
-
- # cd "${pkgdir}"
+ cd usr/local/bin/
+ sed -i "s+usr/local/openresty+opt/openresty+g" kong
+ sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
+ sed -i "s+usr/local/openresty+opt/openresty+g" lapis
+ sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-5.1
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-admin
+ sed -i "s+usr/local/openresty+opt/openresty+g" luarocks-admin-5.1
+ cd "${pkgdir}"
mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin