summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 04:57:50 +0200
committerGoran Nushkov2019-04-06 04:57:50 +0200
commitcaadc3481e4345ff0a40465d2c0a0fe0c2363ef7 (patch)
tree1914c6b351efed018b4202f17e5d4be7be2e6875
parent09acb3b374071c2fa8b0e52dbf5a6532ae6f317f (diff)
downloadaur-caadc3481e4345ff0a40465d2c0a0fe0c2363ef7.tar.gz
Fixed openresty location
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD37
-rw-r--r--kong-community-edition.install5
3 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23461da27ca6..d43de8739ee6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,8 @@ pkgbase = kong-community-edition
arch = any
license = Apache
depends = libyaml
+ depends = lua51
depends = luajit
- depends = luarocks
depends = openresty
depends = openssl
depends = pcre
diff --git a/PKGBUILD b/PKGBUILD
index 5eb1b5ccf2e8..c3a2a5cfe186 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="https://getkong.org"
license=('Apache')
groups=('')
-depends=('libyaml' 'luajit' 'luarocks' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
+depends=('libyaml' 'lua51' 'luajit' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
options=('!strip' '!emptydirs')
install=${pkgname}.install
# source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
@@ -16,28 +16,27 @@ install=${pkgname}.install
# package(){
-# # # Extract package data
-# # tar xzf data.tar.gz -C "${pkgdir}"
+# # Extract package data
+# tar xzf data.tar.gz -C "${pkgdir}"
-# # # Fix directories structure differencies
-# # cd "${pkgdir}"
-
-# # install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-# # install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+# # Fix directories structure differences
+# cd "${pkgdir}"
+# install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+# install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
-# # # # Fix openresty location
-# # cd usr/local/bin/
-# # sed -i "s+usr/local/openresty+opt/openresty+g" kong
-# # sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
-# # sed -i "s+usr/local/openresty+opt/openresty+g" lapis
-# # sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
-# # rm luarocks luarocks-5.1 luarocks-admin luarocks-admin-5.1
-# # cd "${pkgdir}"
+# # # Fix openresty location
+# cd usr/local/bin/
+# sed -i "s+usr/local/openresty+opt/openresty+g" kong
+# sed -i "s+usr/local/openresty+opt/openresty+g" json2lua
+# sed -i "s+usr/local/openresty+opt/openresty+g" lapis
+# sed -i "s+usr/local/openresty+opt/openresty+g" lua2json
+# rm luarocks luarocks-5.1 luarocks-admin luarocks-admin-5.1
+# cd "${pkgdir}"
-# # mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+# mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
-# # rsync -a usr/local/* usr; rm -rf usr/local
+# rsync -a usr/local/* usr; rm -rf usr/local
-# # cd ..
+# cd ..
# }
diff --git a/kong-community-edition.install b/kong-community-edition.install
index d88c5545de72..7eaef3bb6f49 100644
--- a/kong-community-edition.install
+++ b/kong-community-edition.install
@@ -1,6 +1,11 @@
post_install() {
+ pacman -U https://archive.archlinux.org/packages/ ... luarocks-2.4.3-1-any.pkg.tar.xz
echo 'export PATH=/opt/openresty/bin:$PATH' >> ~/.bashrc
echo 'export PATH=/uopt/openresty/bin:/opt/openresty/nginx/sbin:$PATH' >> ~/.bashrc
+ echo 'export LUA_VERSION= ./configure \
+ --lua-suffix=jit \
+ --with-lua=/opt/openresty/luajit \
+ --with-lua-include=/opt/openresty/luajit/include/luajit-2.1' >> ~/.bashrc
source ~/.bashrc
luarocks install kong 1.1.0-0
mkdir -p /etc/kong