summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang.j.k2021-03-06 17:28:21 +0800
committerZhang.j.k2021-03-06 17:32:00 +0800
commit2a88f93026b651b8c9aaa53e25e570767737a55d (patch)
treed1515daaf4534aa29af9aac343dfa5136c1cbfbf
downloadaur-2a88f93026b651b8c9aaa53e25e570767737a55d.tar.gz
init commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD31
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b4e0bab912a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = konsave
+ pkgdesc = A CLI program that will let you save and apply your KDE Plasma customizations with just one command!
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/chakki-works/seqeval
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pyaml
+ source = konsave-1.0.5.tar.gz::https://github.com/Prayag2/konsave/archive/v1.0.5.tar.gz
+ md5sums = fbc80c9f7d3310527a2f6231f8f423a0
+
+pkgname = konsave
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9524ffd7f1f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+*.tar.zst
+pkg/
+src/
+k/
+
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!*.install
+!ChangeLog
+!.SRCINFO
+
+# common wing-man files
+!*.diff
+!*.patch
+
+!README.md \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..470055b9b9a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Zhang.j.k <zhangjk67 at gmail dian com>
+
+pkgbase='konsave'
+pkgname=('konsave')
+pkgver='1.0.5'
+pkgrel=1
+pkgdesc="A CLI program that will let you save and apply your KDE Plasma customizations with just one command!"
+url="https://github.com/chakki-works/seqeval"
+depends=('python' 'python-pyaml')
+makedepends=('python' 'python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Prayag2/konsave/archive/v$pkgver.tar.gz")
+md5sums=('fbc80c9f7d3310527a2f6231f8f423a0')
+
+build() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py build
+}
+
+# check() {
+# cd "${srcdir}/${pkgbase}-${pkgver}"
+# python setup.py pytest
+# }
+
+package() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+