summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2021-03-08 14:43:52 +0100
committerBrody2021-03-08 14:43:52 +0100
commit5b96adcfe245384776476ad13b635576fe2ff1ce (patch)
treece6c7f9db3479a363a92bb9a4b6fe3b91d2d51e8
parent11e11d7639e4dd91c3c3a3b69c164cc5a7ba8ead (diff)
downloadaur-5b96adcfe245384776476ad13b635576fe2ff1ce.tar.gz
Update to 1.1.5
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD39
3 files changed, 23 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 421d30f46f1a..491f4da8ea9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = konsave
- pkgdesc = A CLI program that will let you save and apply your KDE Plasma customizations with just one command!
- pkgver = 1.1.3
- pkgrel = 3
+ pkgdesc = Save and apply your KDE Plasma customizations with just one command!
+ pkgver = 1.1.5
+ pkgrel = 1
url = https://github.com/Prayag2/konsave
arch = any
license = GPL3
makedepends = python-setuptools-scm
depends = python
depends = python-pyaml
- source = konsave-1.1.3.tar.gz::https://github.com/Prayag2/konsave/archive/v1.1.3.tar.gz
- md5sums = SKIP
+ source = konsave-1.1.5.tar.gz::https://github.com/Prayag2/konsave/archive/v1.1.5.tar.gz
+ sha256sums = 33ed39c308151b087b0b078ddfc9d01341fede22e24882d95dc3d8e045a96999
pkgname = konsave
diff --git a/.gitignore b/.gitignore
index 9524ffd7f1f2..d13a8e2ac477 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,20 +1,4 @@
-*.tar.zst
pkg/
src/
-k/
-
-# ignore everything
-*
-!.gitignore
-
-# except PKGBUILD needed files
-!PKGBUILD
-!*.install
-!ChangeLog
-!.SRCINFO
-
-# common wing-man files
-!*.diff
-!*.patch
-
-!README.md \ No newline at end of file
+*.tar*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index d10d10ea6ebf..4f2866bb2e9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,29 @@
-# Maintainer: Zhang.j.k <zhangjk67 at gmail dian com>
-
-pkgbase='konsave'
-pkgname=('konsave')
-pkgver='1.1.3'
-pkgrel=3
-pkgdesc="A CLI program that will let you save and apply your KDE Plasma customizations with just one command!"
-url="https://github.com/Prayag2/konsave"
+# Maintainer: Brody <archfan at brodix dot de>
+# Contributor: Zhang.j.k <zhangjk67 at gmail dian com>
+# vim: ts=2 sw=2 et:
+
+pkgname=konsave
+pkgver=1.1.5
+pkgrel=1
+pkgdesc="Save and apply your KDE Plasma customizations with just one command!"
+url="https://github.com/Prayag2/${pkgname}"
depends=('python' 'python-pyaml')
makedepends=('python-setuptools-scm')
license=('GPL3')
arch=('any')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/Prayag2/konsave/archive/v$pkgver.tar.gz")
-md5sums=("SKIP")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('33ed39c308151b087b0b078ddfc9d01341fede22e24882d95dc3d8e045a96999')
prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
}
build() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python setup.py build
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py build
}
-# check() {
-# cd "${srcdir}/${pkgbase}-${pkgver}"
-# python setup.py pytest
-# }
-
package() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-
-
-