summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2023-01-31 10:16:43 +0100
committerBrody2023-01-31 10:16:43 +0100
commitfa549f1339791a3e75242d6cfb651f0126f20cad (patch)
tree7cda4cd3e88813011ac76e054c54d6ea99814c32
parentf70ebf98e9baf0d73878ab458df27fc61e96360b (diff)
downloadaur-fa549f1339791a3e75242d6cfb651f0126f20cad.tar.gz
Update to 2.2.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD22
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8573525ffc68..497f3c660450 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = konsave
pkgdesc = Save and apply your KDE Plasma customizations with just one command!
- pkgver = 2.1.2
- pkgrel = 2
+ pkgver = 2.2.0
+ pkgrel = 1
url = https://github.com/Prayag2/konsave
arch = any
license = GPL3
makedepends = python-setuptools-scm
- depends = python
depends = python-pyaml
- source = konsave-2.1.2.tar.gz::https://github.com/Prayag2/konsave/archive/v2.1.2.tar.gz
- sha512sums = a07fd19fe0c099e674a42a7894bf306c0e1c59b7d96ad84fa613bd2b60701473d243afde11f17a128362ca7e756f3cbe4d9adb8ffe618319253fda90c568e968
+ source = konsave-2.2.0.tar.gz::https://github.com/Prayag2/konsave/archive/v2.2.0.tar.gz
+ sha512sums = c9f513fb0ff4bad477765e91614295d120af349c6e60f4116ae8a7e0bd205958adc3fa01034183c6d18c127dcb730a93883527053a334496bc16b829cc22aa24
pkgname = konsave
diff --git a/.gitignore b/.gitignore
index d13a8e2ac477..76cdfeea1f71 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
-pkg/
-src/
-*.tar*
-*.log
+/pkg/
+/src/
+/*.t{ar,gz}
+/*.tar.*
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index a08abf4d93d1..09b5fb722d6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,17 @@
# Maintainer: Brody <archfan at brodix dot de>
# Contributor: Zhang.j.k <zhangjk67 at gmail dian com>
-# vim: ts=2 sw=2 et:
pkgname=konsave
-pkgver=2.1.2
-pkgrel=2
-pkgdesc="Save and apply your KDE Plasma customizations with just one command!"
+pkgver=2.2.0
+pkgrel=1
+pkgdesc='Save and apply your KDE Plasma customizations with just one command!'
url="https://github.com/Prayag2/${pkgname}"
-depends=(
- 'python'
- 'python-pyaml'
-)
-makedepends=('python-setuptools-scm')
-license=('GPL3')
-arch=('any')
+depends=(python-pyaml)
+makedepends=(python-setuptools-scm)
+license=(GPL3)
+arch=(any)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha512sums=('a07fd19fe0c099e674a42a7894bf306c0e1c59b7d96ad84fa613bd2b60701473d243afde11f17a128362ca7e756f3cbe4d9adb8ffe618319253fda90c568e968')
+sha512sums=(c9f513fb0ff4bad477765e91614295d120af349c6e60f4116ae8a7e0bd205958adc3fa01034183c6d18c127dcb730a93883527053a334496bc16b829cc22aa24)
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION="${pkgver}"
@@ -35,3 +31,5 @@ package() {
install -Dm644 konsave/conf_kde.yaml "${pkgdir}/${_python_folder}/${pkgname}/conf_kde.yaml"
install -Dm644 konsave/conf_other.yaml "${pkgdir}/${_python_folder}/${pkgname}/conf_other.yaml"
}
+
+# vim: ts=2 sw=2 et: