summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2022-03-31 20:24:01 +0200
committerBrody2022-03-31 20:24:01 +0200
commitfd6783efb41d79e9ad1a936be7ceb3c76820a315 (patch)
treeb0199721ea53883710f0c443c1e5f6d06c02633a
parenteca59367f29ea11372ea9f6ac309c50bbea2d61a (diff)
downloadaur-fd6783efb41d79e9ad1a936be7ceb3c76820a315.tar.gz
Remove strict PyYaml version dependency (thanks @ishaanbhimwal)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba8be7fb350e..e5aaa2004347 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = konsave
pkgdesc = Save and apply your KDE Plasma customizations with just one command!
pkgver = 2.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Prayag2/konsave
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index e79c5f0d39e9..5613b37003ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,24 @@
pkgname=konsave
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Save and apply your KDE Plasma customizations with just one command!"
url="https://github.com/Prayag2/${pkgname}"
-depends=('python' 'python-pyaml')
+depends=(
+ 'python'
+ 'python-pyaml'
+)
makedepends=('python-setuptools-scm')
license=('GPL3')
arch=('any')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha512sums=('291d33e12b9e038257a44015948f8c823872888b12b37f3a2f388cc28d9374bff81f7316098a98f1b460cd8efe7d1f3521999939315487ff0033bac9eb47caea')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i 's/PyYaml==5.4.1/PyYaml>=5.4.1/g' requirements.txt
+}
+
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION="${pkgver}"
cd "${pkgname}-${pkgver}"