summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorleaeasy2016-10-24 22:54:01 +0800
committerleaeasy2016-10-24 22:54:01 +0800
commit0fbfde11b788fb0ee5788890f926d084338b5df8 (patch)
treeb470fdb61bc04aa407044c78636e01c5c1e179d6
downloadaur-0fbfde11b788fb0ee5788890f926d084338b5df8.tar.gz
bump version 16.08.2
-rw-r--r--.SRCINFO29
-rw-r--r--0001-add-blur-effect-when-set-transparency.patch84
-rw-r--r--PKGBUILD43
3 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a1e20215b88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = konsole-blurry
+ pkgdesc = Konsole with blurry support
+ pkgver = 16.08.2
+ pkgrel = 1
+ url = http://kde.org/applications/system/konsole/
+ arch = i686
+ arch = x86_64
+ groups = kde-applications
+ groups = kdebase
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = python
+ depends = knotifyconfig
+ depends = kpty
+ depends = kparts
+ optdepends = kdebase-keditbookmarks: to manage bookmarks
+ provides = konsole
+ conflicts = kdebase-konsole<4.14.3-2
+ replaces = kdebase-konsole
+ source = http://download.kde.org/stable/applications/16.08.2/src/konsole-16.08.2.tar.xz
+ source = 0001-add-blur-effect-when-set-transparency.patch
+ sha1sums = 54eb92f656535c22879db5c23e15625d524a5e95
+ sha1sums = b3f8b444181e8e6f60d15d160375c26804429e9b
+
+pkgname = konsole-blurry
+
diff --git a/0001-add-blur-effect-when-set-transparency.patch b/0001-add-blur-effect-when-set-transparency.patch
new file mode 100644
index 000000000000..66d19c11fb37
--- /dev/null
+++ b/0001-add-blur-effect-when-set-transparency.patch
@@ -0,0 +1,84 @@
+From 20e6d6223e3c14bf173edbf4633859146cb60a97 Mon Sep 17 00:00:00 2001
+From: leaeasy <leaeasy@gmail.com>
+Date: Sun, 23 Oct 2016 20:17:42 +0800
+Subject: [PATCH] add-blur-effect-when-set-transparency
+
+---
+ CMakeLists.txt | 3 ++-
+ src/CMakeLists.txt | 2 ++
+ src/MainWindow.cpp | 11 +++++++++++
+ 3 files changed, 15 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 18b6e49..51f7c0e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,6 +35,7 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED
+ PrintSupport
+ Script
+ Widgets
++ X11Extras
+ )
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+@@ -42,7 +43,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+ CoreAddons Crash GuiAddons DBusAddons
+ I18n IconThemes Init KIO Notifications NotifyConfig
+ Parts Pty Service TextWidgets WidgetsAddons
+- WindowSystem XmlGui DBusAddons
++ WindowSystem XmlGui DBusAddons
+ )
+
+ find_package(KF5DocTools ${KF5_MIN_VERSION})
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 25f6e57..6077ed0 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -108,6 +108,7 @@ set(konsole_LIBS
+ KF5::XmlGui
+ Qt5::PrintSupport
+ Qt5::Xml
++ Qt5::X11Extras
+ KF5::Notifications
+ KF5::WindowSystem
+ KF5::TextWidgets
+@@ -118,6 +119,7 @@ set(konsole_LIBS
+ KF5::Pty
+ KF5::KIOWidgets
+ KF5::DBusAddons
++ ${X11_LIBRARIES}
+ )
+
+ if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
+index 803eeaf..dfca483 100644
+--- a/src/MainWindow.cpp
++++ b/src/MainWindow.cpp
+@@ -56,6 +56,12 @@
+ #include "settings/ProfileSettings.h"
+ #include "settings/TabBarSettings.h"
+
++#ifdef HAVE_X11
++#include <QtX11Extras/QX11Info>
++#include <X11/Xlib.h>
++#include <X11/Xatom.h>
++#endif
++
+ using namespace Konsole;
+
+ MainWindow::MainWindow()
+@@ -135,6 +141,11 @@ void MainWindow::updateUseTransparency()
+ setAttribute(Qt::WA_TranslucentBackground, useTranslucency);
+ setAttribute(Qt::WA_NoSystemBackground, false);
+ WindowSystemInfo::HAVE_TRANSPARENCY = useTranslucency;
++ #ifdef HAVE_X11
++ Atom net_wm_blur_region = XInternAtom(QX11Info::display(), "_KDE_NET_WM_BLUR_BEHIND_REGION", False);
++ unsigned long region[] = { 0 };
++ XChangeProperty(QX11Info::display(), winId(), net_wm_blur_region, XA_CARDINAL, 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&region), 1);
++ #endif
+ }
+
+ void MainWindow::rememberMenuAccelerators()
+--
+2.10.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ba7117c915d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: leaeasy <leaeasy at gmail.com>
+
+pkgname=konsole-blurry
+_pkgname=konsole
+pkgver=16.08.2
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://kde.org/applications/system/konsole/'
+pkgdesc="Konsole with blurry support"
+license=('GPL' 'LGPL' 'FDL')
+groups=('kde-applications' 'kdebase')
+conflicts=('konsole')
+provides=('konsole')
+depends=('knotifyconfig' 'kpty' 'kparts')
+makedepends=('extra-cmake-modules' 'kdoctools' 'python')
+optdepends=('kdebase-keditbookmarks: to manage bookmarks')
+replaces=('kdebase-konsole')
+conflicts=('kdebase-konsole<4.14.3-2')
+source=("http://download.kde.org/stable/applications/${pkgver}/src/konsole-${pkgver}.tar.xz"
+ "0001-add-blur-effect-when-set-transparency.patch")
+sha1sums=('54eb92f656535c22879db5c23e15625d524a5e95'
+ 'b3f8b444181e8e6f60d15d160375c26804429e9b')
+
+prepare() {
+ mkdir -p build
+ cd ${srcdir}/$_pkgname-$pkgver
+ patch -Np1 -i ${srcdir}/0001-add-blur-effect-when-set-transparency.patch
+}
+
+build() {
+ cd build
+ cmake ../$_pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}