summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Seletskiy2017-07-22 16:39:44 +0700
committerStanislav Seletskiy2017-07-22 16:39:51 +0700
commit72b0e8556b7e102199972945d644b2bf17617894 (patch)
tree66e26ba1562234a3aeda93fb76ed3dfcc047322b
parente37fabe7d3b2d1de8ab6ed371c2fc3cac68d0bc3 (diff)
downloadaur-72b0e8556b7e102199972945d644b2bf17617894.tar.gz
use konsole-blurry as template
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--0001-add-blur-effect-when-set-transparency.patch84
-rw-r--r--0001-remove-cursor-height-padding-from-top.patch13
-rw-r--r--PKGBUILD18
5 files changed, 36 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9169e04d0079..83a77a8385ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
-pkgbase = konsole-blurry
- pkgdesc = Konsole with blurry support
- pkgver = 16.12.2
+# Generated by mksrcinfo v8
+# Sat Jul 22 09:39:50 UTC 2017
+pkgbase = konsole-cursor
+ pkgdesc = Konsole with better cursor
+ pkgver = 17.04.3
pkgrel = 1
url = http://kde.org/applications/system/konsole/
arch = i686
@@ -20,10 +22,11 @@ pkgbase = konsole-blurry
provides = konsole
conflicts = kdebase-konsole<4.14.3-2
replaces = kdebase-konsole
- source = http://download.kde.org/stable/applications/16.12.2/src/konsole-16.12.2.tar.xz
- source = 0001-add-blur-effect-when-set-transparency.patch
- sha1sums = d889147f592bcdd40576756a4ba3a861807cee24
- sha1sums = b3f8b444181e8e6f60d15d160375c26804429e9b
+ replaces = konsole
+ source = http://download.kde.org/stable/applications/17.04.3/src/konsole-17.04.3.tar.xz
+ source = 0001-remove-cursor-height-padding-from-top.patch
+ sha1sums = a9a99d46d17f5b49f35e84a9e5cb682658c10716
+ sha1sums = f4c8e0d88c89c43b2863ced4399e6af9683271b5
-pkgname = konsole-blurry
+pkgname = konsole-cursor
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7caf235b600e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.xz
+src/
+pkg/
diff --git a/0001-add-blur-effect-when-set-transparency.patch b/0001-add-blur-effect-when-set-transparency.patch
deleted file mode 100644
index 66d19c11fb37..000000000000
--- a/0001-add-blur-effect-when-set-transparency.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 20e6d6223e3c14bf173edbf4633859146cb60a97 Mon Sep 17 00:00:00 2001
-From: leaeasy <leaeasy@gmail.com>
-Date: Sun, 23 Oct 2016 20:17:42 +0800
-Subject: [PATCH] add-blur-effect-when-set-transparency
-
----
- CMakeLists.txt | 3 ++-
- src/CMakeLists.txt | 2 ++
- src/MainWindow.cpp | 11 +++++++++++
- 3 files changed, 15 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 18b6e49..51f7c0e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -35,6 +35,7 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED
- PrintSupport
- Script
- Widgets
-+ X11Extras
- )
-
- find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
-@@ -42,7 +43,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
- CoreAddons Crash GuiAddons DBusAddons
- I18n IconThemes Init KIO Notifications NotifyConfig
- Parts Pty Service TextWidgets WidgetsAddons
-- WindowSystem XmlGui DBusAddons
-+ WindowSystem XmlGui DBusAddons
- )
-
- find_package(KF5DocTools ${KF5_MIN_VERSION})
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 25f6e57..6077ed0 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -108,6 +108,7 @@ set(konsole_LIBS
- KF5::XmlGui
- Qt5::PrintSupport
- Qt5::Xml
-+ Qt5::X11Extras
- KF5::Notifications
- KF5::WindowSystem
- KF5::TextWidgets
-@@ -118,6 +119,7 @@ set(konsole_LIBS
- KF5::Pty
- KF5::KIOWidgets
- KF5::DBusAddons
-+ ${X11_LIBRARIES}
- )
-
- if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index 803eeaf..dfca483 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -56,6 +56,12 @@
- #include "settings/ProfileSettings.h"
- #include "settings/TabBarSettings.h"
-
-+#ifdef HAVE_X11
-+#include <QtX11Extras/QX11Info>
-+#include <X11/Xlib.h>
-+#include <X11/Xatom.h>
-+#endif
-+
- using namespace Konsole;
-
- MainWindow::MainWindow()
-@@ -135,6 +141,11 @@ void MainWindow::updateUseTransparency()
- setAttribute(Qt::WA_TranslucentBackground, useTranslucency);
- setAttribute(Qt::WA_NoSystemBackground, false);
- WindowSystemInfo::HAVE_TRANSPARENCY = useTranslucency;
-+ #ifdef HAVE_X11
-+ Atom net_wm_blur_region = XInternAtom(QX11Info::display(), "_KDE_NET_WM_BLUR_BEHIND_REGION", False);
-+ unsigned long region[] = { 0 };
-+ XChangeProperty(QX11Info::display(), winId(), net_wm_blur_region, XA_CARDINAL, 32, PropModeReplace, reinterpret_cast<const unsigned char*>(&region), 1);
-+ #endif
- }
-
- void MainWindow::rememberMenuAccelerators()
---
-2.10.1
-
diff --git a/0001-remove-cursor-height-padding-from-top.patch b/0001-remove-cursor-height-padding-from-top.patch
new file mode 100644
index 000000000000..e24cba95abee
--- /dev/null
+++ b/0001-remove-cursor-height-padding-from-top.patch
@@ -0,0 +1,13 @@
+diff --git a/src/TerminalDisplay.cpp b/src/TerminalDisplay.cpp
+index 7b083a6c..f6281e81 100644
+--- a/src/TerminalDisplay.cpp
++++ b/src/TerminalDisplay.cpp
+@@ -763,7 +763,7 @@ void TerminalDisplay::drawCursor(QPainter& painter,
+
+ // shift rectangle top down one pixel to leave some space
+ // between top and bottom
+- QRect cursorRect = rect.adjusted(0, 1, 0, 0);
++ QRect cursorRect = rect.adjusted(0, 0, 0, 0);
+
+ QColor cursorColor = _cursorColor.isValid() ? _cursorColor : foregroundColor;
+ painter.setPen(cursorColor);
diff --git a/PKGBUILD b/PKGBUILD
index 26e932bc4e54..9b022512f218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: leaeasy <leaeasy at gmail.com>
+# Maintainer: Stanislav Seletskiy <s.seletskiy@gmail.com>
-pkgname=konsole-blurry
+pkgname=konsole-cursor
_pkgname=konsole
-pkgver=16.12.2
+pkgver=17.04.3
pkgrel=1
arch=('i686' 'x86_64')
url='http://kde.org/applications/system/konsole/'
-pkgdesc="Konsole with blurry support"
+pkgdesc="Konsole with better cursor"
license=('GPL' 'LGPL' 'FDL')
groups=('kde-applications' 'kdebase')
conflicts=('konsole')
@@ -14,17 +14,17 @@ provides=('konsole')
depends=('knotifyconfig' 'kpty' 'kparts')
makedepends=('extra-cmake-modules' 'kdoctools' 'python')
optdepends=('kdebase-keditbookmarks: to manage bookmarks')
-replaces=('kdebase-konsole')
+replaces=('kdebase-konsole' 'konsole')
conflicts=('kdebase-konsole<4.14.3-2')
source=("http://download.kde.org/stable/applications/${pkgver}/src/konsole-${pkgver}.tar.xz"
- "0001-add-blur-effect-when-set-transparency.patch")
-sha1sums=('d889147f592bcdd40576756a4ba3a861807cee24'
- 'b3f8b444181e8e6f60d15d160375c26804429e9b')
+ "0001-remove-cursor-height-padding-from-top.patch")
+sha1sums=('a9a99d46d17f5b49f35e84a9e5cb682658c10716'
+ 'f4c8e0d88c89c43b2863ced4399e6af9683271b5')
prepare() {
mkdir -p build
cd ${srcdir}/$_pkgname-$pkgver
- patch -Np1 -i ${srcdir}/0001-add-blur-effect-when-set-transparency.patch
+ patch -Np1 -i ${srcdir}/0001-remove-cursor-height-padding-from-top.patch
}
build() {