summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-06-22 12:55:34 +0300
committerCaleb Maclennan2020-06-22 12:55:34 +0300
commitb8346cda78811949792661a75f71b88e94f59d8c (patch)
tree42e8c0b9c20f04049bca1343a5939f9f9544d986
downloadaur-b8346cda78811949792661a75f71b88e94f59d8c.tar.gz
Initial upload: konstruktor-font 1.004-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96aa7ab1b599
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = konstruktor-font
+ pkgdesc = A narrow cousin of another constructivist typeface, Red October
+ pkgver = 1.004
+ pkgrel = 1
+ url = https://www.neogrey.com/portfolio/konstruktor-free-typeface
+ arch = any
+ license = custom:FFPU
+ makedepends = hq
+ source = konstruktor-1.004.zip::https://dl.dafont.com/dl/?f=konstruktor
+ source = font-licenses.html::https://www.neogrey.com/font-licenses
+ sha256sums = 494b9309f5a98d891a206376046ffc19486fafe4044ef92a1b08b62567fa6e61
+ sha256sums = SKIP
+
+pkgname = ttf-konstruktor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0936a046582c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_font=konstruktor
+pkgbase=$_font-font
+pkgname=("ttf-$_font")
+pkgver=1.004
+pkgrel=1
+pkgdesc='A narrow cousin of another constructivist typeface, Red October'
+url="https://www.neogrey.com/portfolio/$_font-free-typeface"
+arch=('any')
+license=('custom:FFPU')
+makedepends=('hq')
+source=("$_font-$pkgver.zip::https://dl.dafont.com/dl/?f=${_font/-/_}"
+ "font-licenses.html::https://www.neogrey.com/font-licenses")
+sha256sums=('494b9309f5a98d891a206376046ffc19486fafe4044ef92a1b08b62567fa6e61'
+ 'SKIP')
+
+build() {
+ hq article text < font-licenses.html > FFPU.txt
+}
+
+package_ttf-konstruktor() {
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}