summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-09-15 12:56:48 -0400
committerzan2020-09-15 12:56:48 -0400
commit77aaf005288f1bff78312dbf46e27f973bea208b (patch)
treed164cdf6b6761b27bdea9544eadf38d74c97ae3e
downloadaur-77aaf005288f1bff78312dbf46e27f973bea208b.tar.gz
1.0.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfd0a7fd1421
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kontrast
+ pkgdesc = Color contrast checker
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://kde.org/applications/en/kontrast
+ arch = x86_64
+ groups = kde-applications
+ groups = kde-graphics
+ license = GPL
+ makedepends = extra-cmake-modules
+ depends = kcoreaddons
+ depends = ki18n
+ depends = kirigami2
+ depends = hicolor-icon-theme
+ source = https://download.kde.org/stable/kontrast/kontrast-1.0.2.tar.xz
+ sha256sums = bd7835e891dc969c6648d64812946ef46a280551f983b45dca4a05b39531dcf7
+
+pkgname = kontrast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef64b492bbf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: zan <zan@420blaze.it>
+
+pkgname=kontrast
+pkgver=1.0.2
+pkgrel=1
+arch=(x86_64)
+url='https://kde.org/applications/en/kontrast'
+pkgdesc="Color contrast checker"
+license=(GPL)
+groups=(kde-applications kde-graphics)
+depends=(kcoreaddons ki18n kirigami2 hicolor-icon-theme)
+makedepends=(extra-cmake-modules)
+optdepends=()
+source=("https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz") # {,.sig}
+sha256sums=('bd7835e891dc969c6648d64812946ef46a280551f983b45dca4a05b39531dcf7')
+#validpgpkeys=(14B0ED91B5783415D0AA1E0A06B35D38387B67BE) # Carl Schwan <carl@carlschwan.eu>
+
+build() {
+ cmake -B build -S $pkgname-$pkgver
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}