summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-09-15 13:03:30 -0400
committerzan2020-09-15 13:10:51 -0400
commitfc170532f83e46e8f9a054d88ca00aaee076d40b (patch)
tree3a16698c524e7f9c2ff9516fca925bb9a30de0eb
downloadaur-fc170532f83e46e8f9a054d88ca00aaee076d40b.tar.gz
initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65bbf712c89b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kontrast-git
+ pkgdesc = Tool to check contrast for colors that allows verifying that your colors are correctly accessible
+ pkgver = v1.0.1.r47.g8c2b1e0
+ pkgrel = 1
+ url = https://invent.kde.org/accessibility/kontrast
+ arch = x86_64
+ groups = kde-applications
+ groups = kde-accessibility
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = kcoreaddons
+ depends = ki18n
+ depends = kirigami2
+ depends = hicolor-icon-theme
+ provides = kontrast
+ conflicts = kontrast
+ source = git+https://invent.kde.org/accessibility/kontrast.git
+ sha256sums = SKIP
+
+pkgname = kontrast-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..988c50c69cd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zan <zan@420blaze.it>
+
+pkgname=kontrast-git
+_name=${pkgname%-git}
+pkgver=v1.0.1.r47.g8c2b1e0
+pkgrel=1
+arch=(x86_64)
+url='https://invent.kde.org/accessibility/kontrast'
+pkgdesc="Tool to check contrast for colors that allows verifying that your colors are correctly accessible"
+license=(GPL)
+groups=(kde-applications kde-accessibility)
+depends=(kcoreaddons ki18n kirigami2 hicolor-icon-theme)
+makedepends=(extra-cmake-modules git)
+conflicts=(kontrast)
+provides=(kontrast)
+source=("git+https://invent.kde.org/accessibility/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S $_name \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}