summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLionel Miller2020-09-06 13:46:54 +0300
committerLionel Miller2020-09-06 13:46:54 +0300
commitcf3683582114877f29bbecca7f9f17db690ccc89 (patch)
tree049252c13b317903b395786144e7d233c18db4df
downloadaur-cf3683582114877f29bbecca7f9f17db690ccc89.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a452f28fb6ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kontur-plugin
+ pkgdesc = Kontur.Plugin is an extension for web browsers that allows users to perform cryptographic operations in SKB Kontur services.
+ pkgver = 4.0.2.130
+ pkgrel = 1
+ url = https://help.kontur.ru/plugin/
+ arch = x86_64
+ license = proprietary
+ depends = gtk3
+ depends = cryptopro-csp-k1
+ source = https://help.kontur.ru/plugin/beta/dist/kontur.plugin_amd64.deb
+ sha512sums = f581ee668dafba6973800af64988335fb19858a2923f0f754dbcc645009b8753d8669ba815a44d7b1794bae6b77878c46a249e13028a108aa1fee6f177fe115f
+
+pkgname = kontur-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ccd0a369323
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lionel Miller <delonorm at gmail dot com>
+
+pkgname=kontur-plugin
+pkgver=4.0.2.130
+pkgrel=1
+pkgdesc="Kontur.Plugin is an extension for web browsers that allows users to perform cryptographic operations in SKB Kontur services."
+arch=('x86_64')
+_filename="kontur.plugin_amd64.deb"
+license=('proprietary')
+depends=(
+ 'gtk3'
+ 'cryptopro-csp-k1'
+)
+url="https://help.kontur.ru/plugin/"
+source=("https://help.kontur.ru/plugin/beta/dist/$_filename")
+sha512sums=('f581ee668dafba6973800af64988335fb19858a2923f0f754dbcc645009b8753d8669ba815a44d7b1794bae6b77878c46a249e13028a108aa1fee6f177fe115f')
+
+package() {
+ bsdtar -xf data.tar.gz -C "$pkgdir/"
+ rm -r "$pkgdir/usr/lib64/" # /usr/lib64 is a symlink to /usr/lib
+}