summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-26 16:36:18 +0100
committerYour Name2021-01-26 16:36:18 +0100
commit6017e53e4408242a0eb14609ea2b774060caf758 (patch)
tree0164c8b775d5a588fe592d40807d42471c25e177
parent07086b05094b38adb2e75a9a476103ab82bab91d (diff)
downloadaur-6017e53e4408242a0eb14609ea2b774060caf758.tar.gz
next iteration
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
-rw-r--r--changelog65
3 files changed, 26 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd66b69a760a..f99f76d19cdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kopano-core-git
pkgdesc = Foundation for groupware messaging enabling clients
- pkgver = 9.0.12
+ pkgver = 10.0.7
pkgrel = 1
url = https://www.kopano.com/
install = install
@@ -23,7 +23,7 @@ pkgbase = kopano-core-git
makedepends = openssl
makedepends = ncurses>=5
makedepends = util-linux-libs
- makedepends = kopano-libvmime>=0.9.2k2
+ makedepends = libvmime>=0.9.2
makedepends = libxml2
makedepends = mariadb-libs>=5.1
makedepends = xapian-core
@@ -55,7 +55,7 @@ pkgbase = kopano-core-git
depends = python-dateutil
depends = python-pilkit
optdepends = gperftools
- provides = kopano-core=9.0.12
+ provides = kopano-core=10.0.7
backup = etc/kopano/*.cfg
source = kopano-core-git::git+https://stash.kopano.io/scm/kc/kopanocore.git#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f99f0eb57938..406fc14d1056 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# User Manual: http://documentation.kopano.io/user_manual_kopanocore
# Migration 7.2.1: https://documentation.kopano.io/kopano_migration_manual/KopanoMigrationManual.pdf
pkgname='kopano-core-git'
-pkgver='9.0.12'
+pkgver='10.0.7'
pkgrel='1'
pkgdesc='Foundation for groupware messaging enabling clients'
groups=(
@@ -28,11 +28,10 @@ _tagPrefix="kopanocore-"
#_tagSuffix=""
_basePkgName="${pkgname//-git/}"
-
if [[ "${pkgname}" == *-git ]];
then
# Version can't be set before pkgver has run
- provides+=("${pkgname//-git/}=${pkgver}")
+ provides+=("${_basePkgName}=${pkgver}")
fi
_gitLogByDay() {
@@ -99,7 +98,7 @@ makedepends=(
'openssl' # for:librcrypto/libssl
'ncurses>=5'
'util-linux-libs' # libuuid
- 'kopano-libvmime>=0.9.2k2' # src:https://aur.archlinux.org/packages/kopano-libvmime/
+ 'libvmime>=0.9.2' # version:>=0.9.2k2 src:https://aur.archlinux.org/packages/kopano-libvmime/
'libxml2'
'mariadb-libs>=5.1' # for:MariaDB Connector/C 3.0 or MySQL Connector/C 5.1
'xapian-core' # version:>=1.2.21
@@ -186,17 +185,24 @@ prepare() {
./bootstrap.sh
}
+# When using official VMIME
+_officialVmimeParameter() {
+ if ! pacman -Qi kopano-libvmime > /dev/null 2> /dev/null \
+ && ! pacman -Qi kopano-libvmime-git > /dev/null 2> /dev/null;
+ then
+ # VMIME_CFLAGS='$(pkg-config vmime --cflags)' VMIME_LIBS='$(pkg-config vmime --libs)'
+ # echo -n "VMIME_CFLAGS=$(pkg-config vmime --cflags) VMIME_LIBS=$(pkg-config vmime --libs)"
+ echo -n "VMIME_CFLAGS='-I/usr/include/vmime/' VMIME_LIBS='-lvmime'"
+ fi
+}
+
# https://stash.kopano.io/projects/KC/repos/kopanocore/browse/Dockerfile.build
build() {
cd ${srcdir}/${pkgname}
- # When using official VMIME
- # https://stash.kopano.io/projects/KC/repos/kopanocore/browse/doc/install.txt#68
- #
- # VMIME_CFLAGS='$(pkg-config vmime --cflags)' \
- # VMIME_LIBS='$(pkg-config vmime --libs)' \
-
./configure \
+`# https://stash.kopano.io/projects/KC/repos/kopanocore/browse/doc/install.txt#68` \
+ $(_officialVmimeParameter) \
`# https://stash.kopano.io/projects/KC/repos/kopanocore/browse/Jenkinsfile` \
TCMALLOC_CFLAGS=' ' \
TCMALLOC_LIBS='-ltcmalloc_minimal' \
diff --git a/changelog b/changelog
index a95b9866f24c..34167b40b43f 100644
--- a/changelog
+++ b/changelog
@@ -18,65 +18,14 @@
[2020-12-24]
* deps
-[2020-12-26]
-* vmime deps
-
-[2020-12-28]
-* set next version
-* formatting and dependencies
-* test version
-* test vmime from kopanp
-
-[2020-12-29]
-* integrate kopano-vmime
-* changed libvmime src. added gperftools. added packaging
-* changed libvmime src. added gperftools. added packagin
-* dont set python path
-
-[2020-12-30]
-* test build
-
-[2020-12-31]
-* test build
-
-[2021-01-02]
-* fix python install path
-* patch
-* package as is
-* set libdir
-* different prefix
-
-[2021-01-03]
-* different prefix
-* change sbin location
-* docs and configs
-* autodetect branch
-* assignment
-* -git test
-
[2021-01-04]
-* -git test
-* finalized -git test
-* add pythen dependencies ; add optional dependencies to make dependencies ; first files for templates
-
-[2021-01-05]
-* webapp first try
-* fixed cp
-* fixed relnotes path
-* removed/added destdir / added ant-contrib
-* fixed path
-
-[2021-01-07]
-* webapp
-
-[2021-01-08]
-* use templates
+* -git/master-packages
-[2021-01-13]
-* distribute /etc/kopano/*.cfg in kopano-core package
+[2021-01-22]
+* changes from 20201207
-[2021-01-14]
-* distribute /etc/kopano/*.cfg in kopano-core package
+[2021-01-23]
+* Fixed build with ICU 68.2-1
-[2021-01-20]
-* handle git builds
+[2021-01-25]
+* update to kopano 10.0.7