summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2022-01-04 12:17:50 +0100
committerYour Name2022-01-04 12:17:50 +0100
commitc5081b2e79ace435e3f1593e8da168a522701355 (patch)
tree6f98019176f736c64c184faf4a93f27b6eecc974
parentf0568a0cdc6d8264379a4982c8706ac12f07f7a0 (diff)
downloadaur-c5081b2e79ace435e3f1593e8da168a522701355.tar.gz
next iteration
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
-rw-r--r--changelog10
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f87b41029778..bea8e9e146af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,8 +32,7 @@ pkgbase = kopano-core-git
makedepends = krb5
makedepends = curl>=7
makedepends = pam>=1
- makedepends = openldap>=2.4
- makedepends = php>=7
+ makedepends = php<8
makedepends = python>=3
makedepends = swig>=2.0
makedepends = libhx>=1.10
diff --git a/PKGBUILD b/PKGBUILD
index f1fd8c85619e..466d304efff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -163,7 +163,7 @@ source=(
md5sums=(
'SKIP'
)
-
+
makedepends=(
# CORE: https://stash.kopano.io/projects/KC/repos/kopanocore/browse/doc/install.txt
# Mandatory build-time dependencies
@@ -190,8 +190,8 @@ makedepends=(
'krb5'
'curl>=7' # libcurl
'pam>=1'
- 'openldap>=2.4'
- 'php>=7'
+ # 'openldap>=2.4' # Not working with openldap 2.6
+ 'php<8'
'python>=3'
'swig>=2.0'
#
@@ -529,4 +529,4 @@ set_config() {
sed -i -z "s|\(.*[^\n]\)|\1\n${config_attribute} = ${config_value}|" ${config_file}
fi
-} \ No newline at end of file
+}
diff --git a/changelog b/changelog
index a3c575ec8037..331061e13da2 100644
--- a/changelog
+++ b/changelog
@@ -40,3 +40,13 @@
[2021-03-10]
* added patch fallbacks
+
+[2021-08-22]
+* added php7* restriction
+
+[2021-08-23]
+* added php7* restriction, php-config path
+* make php74 the default for the build. Please build in Docker.
+
+[2022-01-03]
+* Update PKGBUILD