summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:16:59 +0100
committerYour Name2021-01-21 10:16:59 +0100
commit9e23c923fa4f716c05cb92a670c1a8558b128941 (patch)
treeaee8e4604fcf4348beea67ef712288755eff4187
parent347bee8d8dabe96991eec36171692b982c2bbd63 (diff)
downloadaur-9e23c923fa4f716c05cb92a670c1a8558b128941.tar.gz
next iteration
-rw-r--r--PKGBUILD5
-rw-r--r--changelog4
2 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e172b2acf42..1d4279b50d48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,7 +33,7 @@ _gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
local UNTIL=$NEXT
- local LOG_FORMAT="* %s %an"
+ local LOG_FORMAT="* %s"
git log --no-merges --since="${SINCE}" --until="${UNTIL}" --format="%cd" --date=short --follow . | sort -u | while read DATE ; do
local GIT_PAGER=$(git log --no-merges --reverse --format="${LOG_FORMAT}" --since="${DATE} 00:00:00" --until="${DATE} 23:59:59" --author="${AUTHOR}" --follow . | uniq)
if [ ! -z "$GIT_PAGER" ]
@@ -44,7 +44,8 @@ _gitLogByDay() {
fi
done
}
-if git rev-parse ;
+if [ ! -e "changelog" ] \
+ || git rev-parse ;
then
_gitLogByDay > changelog
changelog="changelog"
diff --git a/changelog b/changelog
index 0cbd679a328e..f8ea320b7ffd 100644
--- a/changelog
+++ b/changelog
@@ -1,6 +1,6 @@
[2020-12-29]
-* integrate kopano-vmime Your Name
+* integrate kopano-vmime
[2021-01-20]
-* handle git builds Your Name
+* handle git builds