summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:02:59 +0100
committerYour Name2021-01-21 10:02:59 +0100
commit366bf00c4a8a7e7cc2da63871fa796b854053d20 (patch)
treeeccb6959721e77e462643769af2fabdf5e8ff1fc
parent4b98f2e23ca2e50816d4420888310e43f8a02900 (diff)
downloadaur-366bf00c4a8a7e7cc2da63871fa796b854053d20.tar.gz
next iteration
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD32
-rw-r--r--changelog10
3 files changed, 33 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4902cf23c5a9..3029e82efea9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,7 @@ pkgbase = kopano-webapp-files-git
depends = php-memcache
depends = memcached
depends = kopano-webapp
+ provides = kopano-webapp-files=4.0.1
source = kopano-webapp-files-git::git+https://stash.kopano.io/scm/kwa/files.git#branch=master
source = kopano-webapp-files.ini
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 960e0468bfd5..d8ecd9c9a917 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,7 @@ depends=(
# _source=
# _tagPrefix=kopanocore-
-_pluginName=${pkgname//kopano-webapp-/}
-_pluginName=${_pluginName//-git/}
+_pluginName=${_basePkgName//kopano-webapp-/}
pkgrel=1
groups=(
@@ -50,6 +49,14 @@ done
#_tagPrefix=""
#_tagSuffix=""
+_basePkgName="${pkgname//-git/}"
+
+if [[ "${pkgname}" == *-git ]];
+then
+ # Version can't be set before pkgver has run
+ provides+=("${pkgname//-git/}=${pkgver}")
+fi
+
_gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
@@ -77,7 +84,7 @@ pkgver() {
if [[ "${pkgname}" == *-git ]];
then
_lastTag=$(git tag -l "${_tagPrefix}*" --sort=v:refname | tail -n 1)
- _revision="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _revision="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
if [ ! -z "${_lastTag}" ];
then
echo "${_lastTag}" | sed "s|${_tagPrefix}\(.*\)${_tagSuffix}|\1.r${_revision}|"
@@ -98,7 +105,7 @@ md5sums+=(
'SKIP'
)
-_phpIni="${pkgname//-git/}.ini"
+_phpIni="${_basePkgName}.ini"
if [ -e "${_phpIni}" ];
then
source+=(
@@ -130,16 +137,21 @@ fi
# template start; name=base-build-webapp; version=1;
# https://wiki.archlinux.org/index.php/Web_application_package_guidelines
-_binDir=usr/share/webapps/${pkgname}
-_confDir=etc/webapps/${pkgname}
+_binDir=usr/share/webapps/${_basePkgName}
+_confDir=etc/webapps/${_basePkgName}
# template start; name=base-build; version=1;
# https://wiki.archlinux.org/index.php/Arch_package_guidelines
#_binDir=
#_confDir=
-_docDir=usr/share/doc/${pkgname}
-_stateDir=var/lib/${pkgname}
-_logDir=var/log/${pkgname}
-_licenseDir=usr/share/licenses/${pkgname}
+
+if [ -z "${_basePkgName}" ];
+then
+ _basePkgName="${pkgname}"
+fi
+_docDir=usr/share/doc/${_basePkgName}
+_stateDir=var/lib/${_basePkgName}
+_logDir=var/log/${_basePkgName}
+_licenseDir=usr/share/licenses/${_basePkgName}
_commonPermissions='u=rwx,g=rx,o=rx u=rw,g=r,o=r'
_securePermissions='u=rwx,g=rx,o= u=rw,g=r,o='
diff --git a/changelog b/changelog
index e69de29bb2d1..5d82e11439d0 100644
--- a/changelog
+++ b/changelog
@@ -0,0 +1,10 @@
+
+[2021-01-08]
+* use templates Your Name
+* first try plugin Your Name
+
+[2021-01-09]
+* first try plugin Your Name
+
+[2021-01-11]
+* use templates Your Name