summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:03:49 +0100
committerYour Name2021-01-21 10:03:49 +0100
commit48cd443dab1f05ecf53af3f09ffd875139f6628f (patch)
tree25820721a5c48bac90a9eca1e8807283af74e380
parent6d7c8ac02f1fca41efb688a7619f854b3db88df6 (diff)
downloadaur-48cd443dab1f05ecf53af3f09ffd875139f6628f.tar.gz
next iteration
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD32
-rw-r--r--changelog6
3 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 702ce7023a57..2bed3c011168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = kopano-webapp-google2fa-git
makedepends = git
makedepends = gzip
depends = kopano-webapp
+ provides = kopano-webapp-google2fa=0.6.0
source = kopano-webapp-google2fa-git::git+https://bitbucket.org/normanth/google2fa.git#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f6f9ada8fddd..826c75d4f582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,7 @@ _tagSuffix=''
# _source=
# _tagPrefix=kopanocore-
-_pluginName=${pkgname//kopano-webapp-/}
-_pluginName=${_pluginName//-git/}
+_pluginName=${_basePkgName//kopano-webapp-/}
pkgrel=1
groups=(
@@ -45,6 +44,14 @@ done
#_tagPrefix=""
#_tagSuffix=""
+_basePkgName="${pkgname//-git/}"
+
+if [[ "${pkgname}" == *-git ]];
+then
+ # Version can't be set before pkgver has run
+ provides+=("${pkgname//-git/}=${pkgver}")
+fi
+
_gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
@@ -72,7 +79,7 @@ pkgver() {
if [[ "${pkgname}" == *-git ]];
then
_lastTag=$(git tag -l "${_tagPrefix}*" --sort=v:refname | tail -n 1)
- _revision="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _revision="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
if [ ! -z "${_lastTag}" ];
then
echo "${_lastTag}" | sed "s|${_tagPrefix}\(.*\)${_tagSuffix}|\1.r${_revision}|"
@@ -93,7 +100,7 @@ md5sums+=(
'SKIP'
)
-_phpIni="${pkgname//-git/}.ini"
+_phpIni="${_basePkgName}.ini"
if [ -e "${_phpIni}" ];
then
source+=(
@@ -125,16 +132,21 @@ fi
# template start; name=base-build-webapp; version=1;
# https://wiki.archlinux.org/index.php/Web_application_package_guidelines
-_binDir=usr/share/webapps/${pkgname}
-_confDir=etc/webapps/${pkgname}
+_binDir=usr/share/webapps/${_basePkgName}
+_confDir=etc/webapps/${_basePkgName}
# template start; name=base-build; version=1;
# https://wiki.archlinux.org/index.php/Arch_package_guidelines
#_binDir=
#_confDir=
-_docDir=usr/share/doc/${pkgname}
-_stateDir=var/lib/${pkgname}
-_logDir=var/log/${pkgname}
-_licenseDir=usr/share/licenses/${pkgname}
+
+if [ -z "${_basePkgName}" ];
+then
+ _basePkgName="${pkgname}"
+fi
+_docDir=usr/share/doc/${_basePkgName}
+_stateDir=var/lib/${_basePkgName}
+_logDir=var/log/${_basePkgName}
+_licenseDir=usr/share/licenses/${_basePkgName}
_commonPermissions='u=rwx,g=rx,o=rx u=rw,g=r,o=r'
_securePermissions='u=rwx,g=rx,o= u=rw,g=r,o='
diff --git a/changelog b/changelog
index e69de29bb2d1..b80f81a2b09a 100644
--- a/changelog
+++ b/changelog
@@ -0,0 +1,6 @@
+
+[2021-01-11]
+* handle repo without tags Your Name
+
+[2021-01-12]
+* handle repo without tags Your Name