summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:18:01 +0100
committerYour Name2021-01-21 10:18:01 +0100
commit92e799e0f6747d40003907bfe08f264a5a628df7 (patch)
treedd35bdfa2b5d5c1f54e3549d7b61846f4c3a538c
parent48cd443dab1f05ecf53af3f09ffd875139f6628f (diff)
downloadaur-92e799e0f6747d40003907bfe08f264a5a628df7.tar.gz
next iteration
-rw-r--r--PKGBUILD5
-rw-r--r--changelog4
2 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 826c75d4f582..e83616e59f98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,7 +56,7 @@ _gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
local UNTIL=$NEXT
- local LOG_FORMAT="* %s %an"
+ local LOG_FORMAT="* %s"
git log --no-merges --since="${SINCE}" --until="${UNTIL}" --format="%cd" --date=short --follow . | sort -u | while read DATE ; do
local GIT_PAGER=$(git log --no-merges --reverse --format="${LOG_FORMAT}" --since="${DATE} 00:00:00" --until="${DATE} 23:59:59" --author="${AUTHOR}" --follow . | uniq)
if [ ! -z "$GIT_PAGER" ]
@@ -67,7 +67,8 @@ _gitLogByDay() {
fi
done
}
-if git rev-parse ;
+if [ ! -e "changelog" ] \
+ || git rev-parse ;
then
_gitLogByDay > changelog
changelog="changelog"
diff --git a/changelog b/changelog
index b80f81a2b09a..dfceb845fb9a 100644
--- a/changelog
+++ b/changelog
@@ -1,6 +1,6 @@
[2021-01-11]
-* handle repo without tags Your Name
+* handle repo without tags
[2021-01-12]
-* handle repo without tags Your Name
+* handle repo without tags