summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:17:20 +0100
committerYour Name2021-01-21 10:17:20 +0100
commit5e532ebbc65676e3f9e13d09d7ba3ae83382816f (patch)
tree6a0880da19fc0515b6b3b0ed92b90fa0f603aace
parent8b76d3470222942904ab367a00b2a4ceece2fd25 (diff)
downloadaur-5e532ebbc65676e3f9e13d09d7ba3ae83382816f.tar.gz
next iteration
-rw-r--r--PKGBUILD5
-rw-r--r--changelog6
2 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94b7ef78a6bc..5e89db0d03ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,7 @@ _gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
local UNTIL=$NEXT
- local LOG_FORMAT="* %s %an"
+ local LOG_FORMAT="* %s"
git log --no-merges --since="${SINCE}" --until="${UNTIL}" --format="%cd" --date=short --follow . | sort -u | while read DATE ; do
local GIT_PAGER=$(git log --no-merges --reverse --format="${LOG_FORMAT}" --since="${DATE} 00:00:00" --until="${DATE} 23:59:59" --author="${AUTHOR}" --follow . | uniq)
if [ ! -z "$GIT_PAGER" ]
@@ -66,7 +66,8 @@ _gitLogByDay() {
fi
done
}
-if git rev-parse ;
+if [ ! -e "changelog" ] \
+ || git rev-parse ;
then
_gitLogByDay > changelog
changelog="changelog"
diff --git a/changelog b/changelog
index 895b156a5c1b..187941102011 100644
--- a/changelog
+++ b/changelog
@@ -1,5 +1,5 @@
[2021-01-11]
-* use templates Your Name
-* add addons Your Name
-* handle repo without tags Your Name
+* use templates
+* add addons
+* handle repo without tags