summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:17:57 +0100
committerYour Name2021-01-21 10:17:57 +0100
commit30c4136cee713441a37ea3c8347bc12ebbad3220 (patch)
tree5fa5ed9cfb97e529248986601911d0cc44efbf4c
parentb744cce7b1ed43e179a07b31d7cdc55268e44346 (diff)
downloadaur-30c4136cee713441a37ea3c8347bc12ebbad3220.tar.gz
next iteration
-rw-r--r--PKGBUILD5
-rw-r--r--changelog4
2 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fea1600a1573..92c5933db346 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,7 +56,7 @@ _gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
local UNTIL=$NEXT
- local LOG_FORMAT="* %s %an"
+ local LOG_FORMAT="* %s"
git log --no-merges --since="${SINCE}" --until="${UNTIL}" --format="%cd" --date=short --follow . | sort -u | while read DATE ; do
local GIT_PAGER=$(git log --no-merges --reverse --format="${LOG_FORMAT}" --since="${DATE} 00:00:00" --until="${DATE} 23:59:59" --author="${AUTHOR}" --follow . | uniq)
if [ ! -z "$GIT_PAGER" ]
@@ -67,7 +67,8 @@ _gitLogByDay() {
fi
done
}
-if git rev-parse ;
+if [ ! -e "changelog" ] \
+ || git rev-parse ;
then
_gitLogByDay > changelog
changelog="changelog"
diff --git a/changelog b/changelog
index ac09cb6488a9..16ad3d1ab6e3 100644
--- a/changelog
+++ b/changelog
@@ -1,6 +1,6 @@
[2021-01-11]
-* add addons Your Name
+* add addons
[2021-01-12]
-* handle repo without tags Your Name
+* handle repo without tags