summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:17:55 +0100
committerYour Name2021-01-21 10:17:55 +0100
commit6887eda9bf735d0f5eb1aad29ea636fd5cf1c954 (patch)
tree458fef02a2f9f00e47a648fa5521e97bb87b5cdd
parent6c8dccd008c33800a657580537d3fd3225f05268 (diff)
downloadaur-6887eda9bf735d0f5eb1aad29ea636fd5cf1c954.tar.gz
next iteration
-rw-r--r--PKGBUILD5
-rw-r--r--changelog2
2 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 468bffc880b1..dd0ede209abe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,7 +55,7 @@ _gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
local UNTIL=$NEXT
- local LOG_FORMAT="* %s %an"
+ local LOG_FORMAT="* %s"
git log --no-merges --since="${SINCE}" --until="${UNTIL}" --format="%cd" --date=short --follow . | sort -u | while read DATE ; do
local GIT_PAGER=$(git log --no-merges --reverse --format="${LOG_FORMAT}" --since="${DATE} 00:00:00" --until="${DATE} 23:59:59" --author="${AUTHOR}" --follow . | uniq)
if [ ! -z "$GIT_PAGER" ]
@@ -66,7 +66,8 @@ _gitLogByDay() {
fi
done
}
-if git rev-parse ;
+if [ ! -e "changelog" ] \
+ || git rev-parse ;
then
_gitLogByDay > changelog
changelog="changelog"
diff --git a/changelog b/changelog
index 99a64b90681a..90c4934062f3 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,3 @@
[2021-01-11]
-* handle repo without tags Your Name
+* handle repo without tags