summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZachary Elliott2016-11-24 21:07:19 -0500
committerZachary Elliott2016-11-24 21:08:31 -0500
commit3a9ebeb3565fd3e466d8b47bdacba2b757f82732 (patch)
tree2e6f300e66a055700c71e26c23bf879d88b99ad3
downloadaur-3a9ebeb3565fd3e466d8b47bdacba2b757f82732.tar.gz
Add kops-v1.4.1 package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..184820a2edc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = kops
+ pkgdesc = Kubernetes Operations (kops) - Production Grade K8s Installation, Upgrades, and Management
+ pkgver = v1.4.1
+ pkgrel = 1
+ url = https://github.com/kubernetes/kops
+ arch = x86_64
+ license = Apache
+ source = https://github.com/kubernetes/kops/releases/download/v1.4.1/kops-linux-amd64
+ sha512sums = 9f182c5278a6b077ac50a05f070cd7969e77fa4d02c1ab13c1ca692175a6a221b405659e91f7b22322671dc19923ae3acd1b45993ac7f50bf6c2d0f7f132800c
+
+pkgname = kops
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6217416e0524
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Zachary Elliott <contact@zell.io>
+# https://github.com/zellio/pkgbuild
+
+pkgname=kops
+pkgver=v1.4.1
+pkgrel=1
+pkgdesc="Kubernetes Operations (kops) - Production Grade K8s Installation, Upgrades, and Management"
+arch=('x86_64')
+url="https://github.com/kubernetes/kops"
+license=('Apache')
+makedepends=()
+
+source=("https://github.com/kubernetes/kops/releases/download/${pkgver}/kops-linux-amd64")
+sha512sums=('9f182c5278a6b077ac50a05f070cd7969e77fa4d02c1ab13c1ca692175a6a221b405659e91f7b22322671dc19923ae3acd1b45993ac7f50bf6c2d0f7f132800c')
+
+package() {
+ install -D -g root -m 0755 -o root "$srcdir/kops-linux-amd64" "$pkgdir/usr/bin/kops"
+}