summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArturo Penen2022-07-08 23:49:18 +0200
committerArturo Penen2022-07-08 23:49:18 +0200
commit82c86d6af5d9a28ae1f13d98ea406899ca8ef733 (patch)
tree1197ebe3c60afc87020b4bfd8d9b90455d77ab28
parent587c47abd3ca1b10afd553a4b2acca7cd5a2278a (diff)
downloadaur-82c86d6af5d9a28ae1f13d98ea406899ca8ef733.tar.gz
Version 1.24.0
Signed-off-by: Arturo Penen <apenen@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e721a2cf1719..309b34d21141 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = kops
pkgdesc = Kubernetes Operations - Production Grade K8s Installation, Upgrades, and Management (build from src)
- pkgver = 1.23.2
+ pkgver = 1.24.0
pkgrel = 1
url = https://github.com/kubernetes/kops
arch = x86_64
license = Apache
makedepends = go
- source = kops-1.23.2.tar.gz::https://github.com/kubernetes/kops/archive/refs/tags/v1.23.2.tar.gz
- sha256sums = adfc507517295fa1c1289528459921abb3e8dad1c7f304f6cd2310382f37c3d0
+ source = kops-1.24.0.tar.gz::https://github.com/kubernetes/kops/archive/refs/tags/v1.24.0.tar.gz
+ sha256sums = 7240c5e3e698a31b81ca4c7c860fb542e03bb505f3fa0a6488a3a3444ba80b68
pkgname = kops
diff --git a/PKGBUILD b/PKGBUILD
index 66a157ff6d34..6d8f6f2cf115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Arturo Penen <apenen@gmail.com>
pkgname=kops
-pkgver=1.23.2
+pkgver=1.24.0
pkgrel=1
pkgdesc='Kubernetes Operations - Production Grade K8s Installation, Upgrades, and Management (build from src)'
arch=('x86_64')
url='https://github.com/kubernetes/kops'
license=('Apache')
source=("$pkgname-$pkgver.tar.gz::https://github.com/kubernetes/kops/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('adfc507517295fa1c1289528459921abb3e8dad1c7f304f6cd2310382f37c3d0')
+sha256sums=('7240c5e3e698a31b81ca4c7c860fb542e03bb505f3fa0a6488a3a3444ba80b68')
makedepends=('go')
build() {
@@ -18,7 +18,7 @@ build() {
}
package() {
- install -Dm 755 "${srcdir}/$pkgname-$pkgver/.build/local/kops" "${pkgdir}/usr/bin/kops"
+ install -Dm 755 "${srcdir}/$pkgname-$pkgver/.build/dist/linux/amd64/kops" "${pkgdir}/usr/bin/kops"
# Populate bash and zsh completions
install -dm 755 "${pkgdir}/usr/share/bash-completion/completions"