summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDisableGraphics2022-04-27 20:41:31 +0200
committerDisableGraphics2022-04-27 20:41:31 +0200
commit0b112dae9da18e56801c8d92c313c02e98d2ccf7 (patch)
treedb2f01776ea1c6d0276531dafab351fa5295d11e
parentfebc196f3447768c0b0a59908be73f46aea8da58 (diff)
downloadaur-0b112dae9da18e56801c8d92c313c02e98d2ccf7.tar.gz
Updated to version V0.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34e13320d377..0ce0159d1a20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = korai-git
+pkgbase = korai
pkgdesc = Fast, reliable and feature-packed manga and comics reader
- pkgver = git
+ pkgver = 0.1.1
pkgrel = 1
arch = any
license = GPL
@@ -10,9 +10,7 @@ pkgbase = korai-git
depends = webkit2gtk
depends = vte3
depends = mangodl
- source = git+http://github.com/DisableGraphics/Korai.git
- source = https://raw.githubusercontent.com/DisableGraphics/Korai/main/src/icon.xpm
- sha512sums = SKIP
- sha512sums = SKIP
+ source = https://github.com/DisableGraphics/Korai/archive/refs/tags/v0.1.1.tar.gz
+ sha512sums = 9c3b91edc7fd01b8d25b3c21f67c72693363fb6577c8480b30c9212fadb530ee46754de8df76144d0b0f620140a492184f1fc333b55306e34f0ed34e4421e6ed
pkgname = korai
diff --git a/PKGBUILD b/PKGBUILD
index 0ec255583fbc..e1cd3503a930 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: DisableGraphics elchifladod@gmail.com
-pkgbase="korai-git"
+pkgbase="korai"
pkgname="korai"
pkgrel=1
-pkgver=git
+pkgver=0.1.1
pkgdesc="Fast, reliable and feature-packed manga and comics reader"
arch=("any")
makedepends=("git")
depends=("libarchive" "gtkmm3" "webkit2gtk" "vte3" "mangodl")
license=("GPL")
-source=("git+http://github.com/DisableGraphics/Korai.git" "https://raw.githubusercontent.com/DisableGraphics/Korai/main/src/icon.xpm")
-sha512sums=("SKIP" "SKIP")
+source=('https://github.com/DisableGraphics/Korai/archive/refs/tags/v0.1.1.tar.gz')
+sha512sums=('9c3b91edc7fd01b8d25b3c21f67c72693363fb6577c8480b30c9212fadb530ee46754de8df76144d0b0f620140a492184f1fc333b55306e34f0ed34e4421e6ed')
prepare() {
- cd Korai
+ tar xf v${pkgver}.tar.gz
+ cd ${srcdir}/Korai-${pkgver}/
make -j$(nproc)
- cd ..
}
package() {
mkdir -p "${pkgdir}/usr/"
@@ -21,8 +21,8 @@ package() {
mkdir -p "${pkgdir}/usr/share/"
mkdir -p "${pkgdir}/usr/share/icons/"
- cp Korai/build/* "${pkgdir}/usr/bin/"
- cp icon.xpm "${pkgdir}/usr/share/icons/korai.xpm"
+ cp ${srcdir}/Korai-${pkgver}/build/korai "${pkgdir}/usr/bin/"
+ cp ${srcdir}/Korai-${pkgver}/src/icon.xpm "${pkgdir}/usr/share/icons/korai.xpm"
mkdir -p "${pkgdir}/usr/share/applications/"