summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2015-12-12 21:53:42 -0400
committerjgmdev2015-12-12 21:53:42 -0400
commit73fd34db7bb7643c179be18674f575b1b664ba6f (patch)
tree65c287ce23efe4fffaf6307a442e08a918340e64
downloadaur-73fd34db7bb7643c179be18674f575b1b664ba6f.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..909a32df8ec4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 01:50:02 UTC 2015
+pkgbase = kore-git
+ pkgdesc = An easy to use, scalable and secure web application framework for writing web APIs in C.
+ pkgver = 1.2.3.release.r76.g5f77092
+ pkgrel = 1
+ url = https://kore.io/
+ arch = i686
+ arch = x86_64
+ license = ISC
+ depends = openssl
+ depends = postgresql-libs
+ provides = kore
+ conflicts = kore
+ source = git://github.com/jorisvink/kore
+ md5sums = SKIP
+
+pkgname = kore-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ab25aac3a82c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+kore/
+pkg/
+src/
+*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68314374b154
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
+# Contributor: Jefferson Gonzalez <jgmdev@gmail.com>
+
+pkgname=kore-git
+_gitname=kore
+pkgver=1.2.3.release.r76.g5f77092
+pkgrel=1
+pkgdesc="An easy to use, scalable and secure web application framework for writing web APIs in C."
+arch=('i686' 'x86_64')
+url="https://kore.io/"
+license=('ISC')
+depends=('openssl' 'postgresql-libs')
+conflicts=('kore')
+provides=('kore')
+source=(git://github.com/jorisvink/kore)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+
+ PREFIX=/usr TASKS=1 PGSQL=1 make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ make INSTALL_DIR="${pkgdir}/usr/bin" INCLUDE_DIR="${pkgdir}/usr/include/kore" install
+
+ mkdir -p "${pkgdir}/usr/share/doc/kore/"
+ install -m 644 "${srcdir}/${_gitname}/conf/kore.conf.example" "${pkgdir}/usr/share/doc/kore/"
+ install -m 644 "${srcdir}/${_gitname}/README.md" "${pkgdir}/usr/share/doc/kore/"
+ cp -r "${srcdir}/${_gitname}/examples" "${pkgdir}/usr/share/doc/kore/"
+} \ No newline at end of file