summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigitalone2019-04-11 16:28:48 +0200
committerdigitalone2019-04-11 16:28:48 +0200
commit1d156824d737c64af462982316a503e45dc07ebf (patch)
treed6ff963b6f6031021995efb84ddc34f14d5baba6
parent730d079345db594d67965b69e8d5d930c9a1ea94 (diff)
downloadaur-1d156824d737c64af462982316a503e45dc07ebf.tar.gz
use install command rather than mkdir and syntax fixed in PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68b4b6156dc5..f0d3b451d3a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = korla-icon-theme
pkgdesc = Korla icon theme suitable for every desktop environment, dark and light versions
pkgver = 1.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/bikass/korla
install = korla-icon-theme.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index b354e7a00280..f530d93ff0f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=korla-icon-theme
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="Korla icon theme suitable for every desktop environment, dark and light versions"
arch=("any")
url="https://github.com/bikass/korla"
@@ -19,19 +19,24 @@ md5sums=("a52a1b62ed2dbed2223ea0ec41a97370")
_iconpath=usr/share/icons
package() {
- mkdir -p "$pkgdir/$_iconpath"
- mkdir -p "$pkgdir/usr/share/doc/$pkgname"
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
-
+ install -dm755 "$pkgdir/$_iconpath"
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+
+ # The following --no-preserve=mode option is necessary since the creator works with
+ # the theme locally and he messed with modes in the past making some icons unreadable
+ # and some directories not executable if installed system wide while he didn't notice
+ # any issue because he installed the theme under the local icon folder on his system.
cd "$srcdir/korla-$pkgver"
- cp -drf --no-preserve=mode,ownership "korla" "$pkgdir/$_iconpath/korla"
- cp -drf --no-preserve=mode,ownership "korla-light" "$pkgdir/$_iconpath/korla-light"
- cp -drf --no-preserve=mode,ownership "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ cp -dr --no-preserve=mode "korla" "$pkgdir/$_iconpath/korla"
+ cp -dr --no-preserve=mode "korla-light" "$pkgdir/$_iconpath/korla-light"
- cd "$pkgdir/$_iconpath"
- mv "korla/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "korla/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgdir/$_iconpath"
rm -f "korla/create-new-icon-theme.cache.sh"
rm -f "korla-light/create-new-icon-theme.cache.sh"
+ rm -f "korla/LICENSE"
rm -f "korla-light/LICENSE"
}