summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigitalone2019-07-20 12:15:59 +0200
committerdigitalone2019-07-20 12:15:59 +0200
commit7c64b949302bd0c9673219c4575207ebeae2a7b0 (patch)
tree0316faf03478f40390bbd34f3402dfad366983f3
downloadaur-7c64b949302bd0c9673219c4575207ebeae2a7b0.tar.gz
first commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
-rw-r--r--korla-icon-theme-git.install14
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2e0160d2542
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = korla-icon-theme-git
+ pkgdesc = SVG icon theme suitable for every desktop environment (dark and light versions, HiDPI support, git version)
+ pkgver = 1.1.4.r286.a450e7c3
+ pkgrel = 1
+ url = https://github.com/bikass/korla
+ install = korla-icon-theme-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-update-icon-cache
+ optdepends = hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme
+ optdepends = breeze-icons: fallback Breeze icon theme
+ optdepends = gnome-icon-theme: fallback Gnome icon theme
+ provides = korla-icon-theme
+ conflicts = korla-icon-theme
+ source = git+https://github.com/bikass/korla.git
+ md5sums = SKIP
+
+pkgname = korla-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e18d1c18b83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Giusy Margarita <kurmikon at libero dot it>
+
+_relver=1.1.4
+
+pkgname=korla-icon-theme-git
+pkgver=$_relver.r286.a450e7c3
+pkgrel=1
+pkgdesc="SVG icon theme suitable for every desktop environment (dark and light versions, HiDPI support, git version)"
+arch=("any")
+url="https://github.com/bikass/korla"
+license=("GPL3")
+depends=("gtk-update-icon-cache")
+optdepends=(
+ "hicolor-icon-theme: fallback Freedesktop.org Hicolor icon theme"
+ "breeze-icons: fallback Breeze icon theme"
+ "gnome-icon-theme: fallback Gnome icon theme")
+makedepends=("git")
+provides=("korla-icon-theme")
+conflicts=("korla-icon-theme")
+install="$pkgname.install"
+source=("git+https://github.com/bikass/korla.git")
+md5sums=("SKIP")
+
+_iconpath=usr/share/icons
+_iconcache=icon-theme.cache
+
+pkgver() {
+ cd "$srcdir/korla"
+
+ # Git, no tags available
+ printf "$_relver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/korla"
+
+ # Delete useless files from source folder
+ rm -f "korla/create-new-icon-theme.cache.sh"
+ rm -f "korla/$_iconcache"
+ rm -f "korla-light/create-new-icon-theme.cache.sh"
+ rm -f "korla-light/$_iconcache"
+
+ install -dm755 "$pkgdir/$_iconpath"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+
+ # The following --no-preserve=mode option is necessary since the creator works with
+ # the theme locally and he messed with modes in the past making some icons unreadable
+ # and some directories not executable if installed system wide while he didn't notice
+ # any issue because he installed the theme under the local icon folder on his system.
+ cp -dr --no-preserve=mode "korla" "$pkgdir/$_iconpath/korla"
+ cp -dr --no-preserve=mode "korla-light" "$pkgdir/$_iconpath/korla-light"
+
+ # Create empty icon cache files, they will be filled during post_install and
+ # post_upgrade scripts
+ touch -a "$pkgdir/$_iconpath/korla/$_iconcache"
+ touch -a "$pkgdir/$_iconpath/korla-light/$_iconcache"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/korla-icon-theme-git.install b/korla-icon-theme-git.install
new file mode 100644
index 000000000000..e3e460d00470
--- /dev/null
+++ b/korla-icon-theme-git.install
@@ -0,0 +1,14 @@
+_iconpath=usr/share/icons
+
+_gtk_icon_cache() {
+ gtk-update-icon-cache -f -t "/$_iconpath/korla/"
+ gtk-update-icon-cache -f -t "/$_iconpath/korla-light/"
+}
+
+post_install() {
+ _gtk_icon_cache
+}
+
+post_upgrade() {
+ _gtk_icon_cache
+}