summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolopasha2021-12-14 19:38:52 +0300
committersolopasha2021-12-14 21:01:31 +0300
commit08c8206a5435f3d4c942fad0193a44a6a1204e68 (patch)
tree02d74c64538d059399bffb7055a8d4e04947877e
parent73ed33d8a35ecc157c76f1ce1f8dc45b9f5a6461 (diff)
downloadaur-08c8206a5435f3d4c942fad0193a44a6a1204e68.tar.gz
Fix tg_owt loading
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c47c4a5e3cc..58c4e12b16fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kotatogram-desktop
pkgdesc = Kotatogram – experimental Telegram Desktop fork
pkgver = 1.4.5
- pkgrel = 1
+ pkgrel = 2
url = https://kotatogram.github.io
arch = x86_64
license = GPL3
@@ -14,6 +14,20 @@ pkgbase = kotatogram-desktop
makedepends = microsoft-gsl
makedepends = extra-cmake-modules
makedepends = webkit2gtk
+ makedepends = unzip
+ makedepends = protobuf
+ makedepends = libxrandr
+ makedepends = libxcomposite
+ makedepends = openssl
+ makedepends = glibc
+ makedepends = ffmpeg
+ makedepends = libva
+ makedepends = opus
+ makedepends = yasm
+ makedepends = libjpeg-turbo
+ makedepends = pipewire
+ makedepends = libxtst
+ makedepends = abseil-cpp
depends = hunspell
depends = ffmpeg
depends = hicolor-icon-theme
@@ -30,7 +44,7 @@ pkgbase = kotatogram-desktop
depends = glibmm
depends = rnnoise
depends = jemalloc
- depends = libtg_owt
+ depends = abseil-cpp
optdepends = webkit2gtk: embedded browser features
optdepends = xdg-desktop-portal: desktop integration
conflicts = kotatogram-desktop-bin
@@ -55,6 +69,10 @@ pkgbase = kotatogram-desktop
source = kotatogram-desktop-tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git
source = kotatogram-desktop-lib_webview::git+https://github.com/desktop-app/lib_webview.git
source = kotatogram-desktop-lib_waylandshells::git+https://github.com/desktop-app/lib_waylandshells.git
+ source = kotatogram-desktop-tg_owt::git+https://github.com/desktop-app/tg_owt.git#commit=91d836dc84
+ source = libvpx::git+https://chromium.googlesource.com/webm/libvpx.git
+ source = libyuv::git+https://chromium.googlesource.com/libyuv/libyuv.git
+ source = pipewire::git+https://github.com/PipeWire/pipewire.git
source = 0001-Add-an-option-to-hide-messages-from-blocked-users-in.patch
sha512sums = SKIP
sha512sums = SKIP
@@ -76,6 +94,10 @@ pkgbase = kotatogram-desktop
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = 6d230d9b4ec64911635f3cb4b301b94ef101722480e0a890704a66f3ed8d610fab985dcb890f006cc774665ba2f3b9546e17ba8342560b11c06d3c6b0b9a96ad
pkgname = kotatogram-desktop
diff --git a/PKGBUILD b/PKGBUILD
index cbf3c2c679aa..a9a255963ddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: Ilya Fedin <fedin-ilja2010@ya.ru>
+# Maintainer: solopasha <daron439 at gmail dot com>
+# Contributor: Ilya Fedin <fedin-ilja2010@ya.ru>
# Contributor: Auteiy <dmitry@auteiy.me>
pkgname=kotatogram-desktop
pkgver=1.4.5
-pkgrel=1
+pkgrel=2
pkgdesc='Kotatogram – experimental Telegram Desktop fork'
arch=('x86_64')
url="https://kotatogram.github.io"
license=('GPL3')
+_tg_owt_commit=91d836dc84
depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
'qt5-imageformats' 'qt5-svg' 'qt5-wayland' 'libdbusmenu-qt5' 'xxhash' 'kwayland' 'glibmm'
- 'rnnoise' 'jemalloc' 'libtg_owt')
+ 'rnnoise' 'jemalloc' 'abseil-cpp')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl'
- 'extra-cmake-modules' 'webkit2gtk')
+ 'extra-cmake-modules' 'webkit2gtk' 'unzip' 'protobuf' 'libxrandr' 'libxcomposite' 'openssl' 'glibc'
+ 'ffmpeg' 'libva' 'opus' 'yasm' 'libjpeg-turbo' 'pipewire' 'libxtst')
optdepends=('webkit2gtk: embedded browser features'
'xdg-desktop-portal: desktop integration')
conflicts=('kotatogram-desktop-bin' 'kotatogram-desktop-dynamic-bin')
@@ -35,6 +38,10 @@ source=("${pkgname}::git+https://github.com/kotatogram/${pkgname}.git#tag=k${pkg
"${pkgname}-tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git"
"${pkgname}-lib_webview::git+https://github.com/desktop-app/lib_webview.git"
"${pkgname}-lib_waylandshells::git+https://github.com/desktop-app/lib_waylandshells.git"
+ "${pkgname}-tg_owt::git+https://github.com/desktop-app/tg_owt.git#commit=${_tg_owt_commit}"
+ "libvpx::git+https://chromium.googlesource.com/webm/libvpx.git"
+ "libyuv::git+https://chromium.googlesource.com/libyuv/libyuv.git"
+ "pipewire::git+https://github.com/PipeWire/pipewire.git"
"0001-Add-an-option-to-hide-messages-from-blocked-users-in.patch")
sha512sums=('SKIP'
'SKIP'
@@ -56,6 +63,10 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'6d230d9b4ec64911635f3cb4b301b94ef101722480e0a890704a66f3ed8d610fab985dcb890f006cc774665ba2f3b9546e17ba8342560b11c06d3c6b0b9a96ad')
prepare() {
@@ -81,16 +92,30 @@ prepare() {
git config submodule.Telegram/lib_webview.url "${srcdir}/${pkgname}-lib_webview"
git config submodule.Telegram/lib_waylandshells.url "${srcdir}/${pkgname}-lib_waylandshells"
git submodule update
-
- patch -p1 < ${srcdir}/0001-Add-an-option-to-hide-messages-from-blocked-users-in.patch
+ patch -p1 < "${srcdir}/0001-Add-an-option-to-hide-messages-from-blocked-users-in.patch"
+ cd "${srcdir}/${pkgname}-tg_owt"
+ git submodule init
+ git config submodule.src/third_party/libvpx/source/libvpx.url "$srcdir"/libvpx
+ git config submodule.src/third_party/libyuv.url "$srcdir"/libyuv
+ git config submodule.src/third_party/pipewire.url "$srcdir"/pipewire
+ git submodule update
}
build() {
- cd "${srcdir}/${pkgname}"
+ # kotatogram-desktop is incompatible with the latest community/libtg_owt, so bundle an older one.
+ cd "${srcdir}/${pkgname}-tg_owt"
+ cmake -B build -G Ninja . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DTG_OWT_BUILD_AUDIO_BACKENDS=OFF \
+ -DBUILD_SHARED_LIBS=OFF
+ cmake --build build
+
+ cd "${srcdir}/${pkgname}"
cmake -B build -G Ninja . \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_BUILD_TYPE=Release \
+ -Dtg_owt_DIR="${srcdir}/${pkgname}-tg_owt/build" \
-DTDESKTOP_API_TEST=ON
cmake --build build