summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Fedin2020-03-19 00:19:41 +0400
committerIlya Fedin2020-03-19 00:19:41 +0400
commit20afd228b52a7d619711f71f0ec7d98cc42149bc (patch)
treeb7df1d13b48f3324b2968afd1ec287301f17d7de
parent8c95cd0640394f16423cd8a272dc7398308b38a7 (diff)
downloadaur-20afd228b52a7d619711f71f0ec7d98cc42149bc.tar.gz
Update to k1.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--system-tray-icon.patch77
3 files changed, 18 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71c3a5f81c43..673dd411eac6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kotatogram-desktop
pkgdesc = Kotatogram – experimental Telegram Desktop fork
- pkgver = 1.1.6
+ pkgver = 1.2
pkgrel = 1
url = https://kotatogram.github.io
arch = x86_64
@@ -9,8 +9,9 @@ pkgbase = kotatogram-desktop
makedepends = python
makedepends = cmake
makedepends = ninja
+ makedepends = microsoft-gsl
+ makedepends = tl-expected
makedepends = range-v3
- makedepends = enchant
depends = qt5-base
depends = qt5-imageformats
depends = ffmpeg
@@ -21,18 +22,19 @@ pkgbase = kotatogram-desktop
depends = zlib
depends = minizip
depends = openssl
+ depends = libdbusmenu-qt5
+ depends = hunspell
depends = libtgvoip
- depends = rlottie-tdesktop
depends = hicolor-icon-theme
depends = desktop-file-utils
- optdepends = enchant: spellchecking support
optdepends = ttf-opensans: default Open Sans font family
conflicts = kotatogram-desktop-bin
conflicts = kotatogram-desktop-dynamic-bin
- source = kotatogram-desktop::git+https://github.com/kotatogram/kotatogram-desktop.git#tag=k1.1.6
+ source = kotatogram-desktop::git+https://github.com/kotatogram/kotatogram-desktop.git#tag=k1.2
source = Catch2::git+https://github.com/catchorg/Catch2.git
source = crl::git+https://github.com/telegramdesktop/crl.git
source = GSL::git+https://github.com/Microsoft/GSL.git
+ source = libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
source = lz4::git+https://github.com/lz4/lz4.git
source = rlottie::git+https://github.com/desktop-app/rlottie.git
@@ -47,7 +49,6 @@ pkgbase = kotatogram-desktop
source = lib_spellcheck::git+https://github.com/desktop-app/lib_spellcheck.git
source = lib_tl::git+https://github.com/desktop-app/lib_tl.git
source = lib_ui::git+https://github.com/kotatogram/lib_ui.git
- source = system-tray-icon.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
@@ -66,7 +67,7 @@ pkgbase = kotatogram-desktop
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 6bdb73dd7ebd8cd50da0f09f2f1fa201e687fee949c4a05f90e62e7e6167ccca877a078021ca611ce8fbb464aab329b92270f07e0cb770c2b7a89a436d37549a
+ sha512sums = SKIP
pkgname = kotatogram-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 9301a3722786..d222b09123d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Auteiy <dmitry@auteiy.me>
pkgname=kotatogram-desktop
-pkgver=1.1.6
+pkgver=1.2
pkgrel=1
pkgdesc="Kotatogram – experimental Telegram Desktop fork"
arch=(x86_64)
@@ -19,8 +19,9 @@ depends=(
zlib
minizip
openssl
+ libdbusmenu-qt5
+ hunspell
libtgvoip
- rlottie-tdesktop
hicolor-icon-theme
desktop-file-utils
)
@@ -29,11 +30,11 @@ makedepends=(
python
cmake
ninja
+ microsoft-gsl
+ tl-expected
range-v3
- enchant
)
optdepends=(
- 'enchant: spellchecking support'
'ttf-opensans: default Open Sans font family'
)
conflicts=('kotatogram-desktop-bin' 'kotatogram-desktop-dynamic-bin')
@@ -43,6 +44,7 @@ source=(
"Catch2::git+https://github.com/catchorg/Catch2.git"
"crl::git+https://github.com/telegramdesktop/crl.git"
"GSL::git+https://github.com/Microsoft/GSL.git"
+ "libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git"
"libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git"
"lz4::git+https://github.com/lz4/lz4.git"
"rlottie::git+https://github.com/desktop-app/rlottie.git"
@@ -57,8 +59,6 @@ source=(
"lib_spellcheck::git+https://github.com/desktop-app/lib_spellcheck.git"
"lib_tl::git+https://github.com/desktop-app/lib_tl.git"
"lib_ui::git+https://github.com/kotatogram/lib_ui.git"
-
- "system-tray-icon.patch"
)
sha512sums=('SKIP'
'SKIP'
@@ -78,7 +78,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '6bdb73dd7ebd8cd50da0f09f2f1fa201e687fee949c4a05f90e62e7e6167ccca877a078021ca611ce8fbb464aab329b92270f07e0cb770c2b7a89a436d37549a')
+ 'SKIP')
prepare() {
cd "$srcdir/$pkgname"
@@ -87,6 +87,7 @@ prepare() {
git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch2"
git config submodule.Telegram/ThirdParty/crl.url "$srcdir/crl"
git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
+ git config submodule.Telegram/ThirdParty/libdbusmenu-qt.url "$srcdir/libdbusmenu-qt"
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git config submodule.Telegram/ThirdParty/lz4.url "$srcdir/lz4"
git config submodule.Telegram/ThirdParty/rlottie.url "$srcdir/rlottie"
@@ -105,8 +106,6 @@ prepare() {
git config submodule.Telegram/lib_ui.url "$srcdir/lib_ui"
git submodule update
-
- patch -Np1 -i "$srcdir/system-tray-icon.patch"
}
build() {
@@ -116,7 +115,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DTDESKTOP_API_TEST=ON \
- -DTDESKTOP_DISABLE_GTK_INTEGRATION=ON
+ -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF \
+ -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
cmake --build .
}
diff --git a/system-tray-icon.patch b/system-tray-icon.patch
deleted file mode 100644
index 51a8e370d0ad..000000000000
--- a/system-tray-icon.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/Telegram/SourceFiles/platform/linux/main_window_linux.cpp b/Telegram/SourceFiles/platform/linux/main_window_linux.cpp
-index d076b90f3..7c40ecb90 100644
---- a/Telegram/SourceFiles/platform/linux/main_window_linux.cpp
-+++ b/Telegram/SourceFiles/platform/linux/main_window_linux.cpp
-@@ -42,6 +42,7 @@ int32 _trayIconSize = 22;
- bool _trayIconMuted = true;
- int32 _trayIconCount = 0;
- QImage _trayIconImageBack, _trayIconImage;
-+QString _trayIconThemeName, _trayIconName;
- QString _desktopFile;
- QString _dbusPath = "/";
-
-@@ -83,17 +84,32 @@ QImage _trayIconImageGen() {
- const auto counterSlice = (counter >= 1000)
- ? (1000 + (counter % 100))
- : counter;
-- if (_trayIconImage.isNull() || _trayIconImage.width() != _trayIconSize || muted != _trayIconMuted || counterSlice != _trayIconCount) {
-- if (_trayIconImageBack.isNull() || _trayIconImageBack.width() != _trayIconSize) {
-- _trayIconImageBack = Core::App().logo().scaled(_trayIconSize, _trayIconSize, Qt::IgnoreAspectRatio, Qt::SmoothTransformation);
-+
-+ QString iconThemeName = QIcon::themeName();
-+ QString iconName = (counter > 0) ? (muted ? "telegram-mute-panel" : "telegram-attention-panel")
-+ : "telegram-panel";
-+
-+ if (_trayIconImage.isNull() || _trayIconImage.width() != _trayIconSize ||
-+ iconThemeName != _trayIconThemeName || iconName != _trayIconName ||
-+ muted != _trayIconMuted || counterSlice != _trayIconCount) {
-+ if (_trayIconImageBack.isNull() || _trayIconImageBack.width() != _trayIconSize ||
-+ iconThemeName != _trayIconThemeName || iconName != _trayIconName) {
-+ _trayIconImageBack = QIcon::fromTheme(iconName, QIcon::fromTheme("kotatogram", QIcon(QPixmap::fromImage(Core::App().logo()))))
-+ .pixmap(256, 256).toImage();
-+ _trayIconImageBack = _trayIconImageBack.scaled(_trayIconSize, _trayIconSize, Qt::IgnoreAspectRatio, Qt::SmoothTransformation);
- _trayIconImageBack = _trayIconImageBack.convertToFormat(QImage::Format_ARGB32);
- }
-+
- _trayIconImage = _trayIconImageBack;
- _trayIconMuted = muted;
- _trayIconCount = counterSlice;
-+ _trayIconThemeName = iconThemeName;
-+ _trayIconName = iconName;
-+
- if (counter > 0) {
- QPainter p(&_trayIconImage);
- int32 layerSize = -16;
-+
- if (_trayIconSize >= 48) {
- layerSize = -32;
- } else if (_trayIconSize >= 36) {
-@@ -101,12 +117,15 @@ QImage _trayIconImageGen() {
- } else if (_trayIconSize >= 32) {
- layerSize = -20;
- }
-+
- auto &bg = (muted ? st::trayCounterBgMute : st::trayCounterBg);
- auto &fg = st::trayCounterFg;
- auto layer = App::wnd()->iconWithCounter(layerSize, counter, bg, fg, false);
-+
- p.drawImage(_trayIconImage.width() - layer.width() - 1, _trayIconImage.height() - layer.height() - 1, layer);
- }
- }
-+
- return _trayIconImage;
- }
-
-@@ -115,7 +134,11 @@ QString _trayIconImageFile() {
- const auto muted = Core::App().unreadBadgeMuted();
- const auto counterSlice = (counter >= 1000) ? (1000 + (counter % 100)) : counter;
-
-- QString name = cWorkingDir() + qsl("tdata/ticons/icon%1_%2_%3.png").arg(muted ? "mute" : "").arg(_trayIconSize).arg(counterSlice);
-+ QString iconThemeName = QIcon::themeName();
-+
-+ QString name = cWorkingDir() + qsl("tdata/ticons/icon%1_%2_%3_%4.png").arg(muted ? "mute" : "").arg(iconThemeName)
-+ .arg(_trayIconSize).arg(counterSlice);
-+
- QFileInfo info(name);
- if (info.exists()) return name;
-