summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Porunov2019-11-18 13:05:45 +0000
committerDmitry Porunov2019-11-18 13:05:45 +0000
commit9b5165280f2f5670f4e3739177d9c6b8a516c858 (patch)
treebb8654bc6018749360793cbe40ae15d99c4ffb8c
parent237b82556ff72d83f35012d0e3df38c89a9dcc15 (diff)
downloadaur-9b5165280f2f5670f4e3739177d9c6b8a516c858.tar.gz
Release k1.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD16
3 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 280ff29a86f9..4b068d4fe9cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,11 @@ pkgbase = kotatogram-desktop
depends = qt5-imageformats
depends = openssl
optdepends = libnotify: desktop notifications
- source = kotatogram-desktop-1.1.1::git+https://github.com/kotatogram/kotatogram-desktop.git#tag=k1.1.1
+ provides = kotatogram-desktop
+ conflicts = kotatogram-desktop-bin
+ conflicts = telegram-desktop
+ conflicts = telegram-desktop-bin
+ source = kotatogram-desktop-1.1.1-1::git+https://github.com/kotatogram/kotatogram-desktop.git#tag=k1.1.1
source = Catch2::git+https://github.com/catchorg/Catch2.git
source = crl::git+https://github.com/telegramdesktop/crl.git
source = GSL::git+https://github.com/Microsoft/GSL.git
diff --git a/.gitignore b/.gitignore
index 96a5330066eb..5193133398c0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,9 @@
Catch2/
-GSL/
+codegen/
crl/
+GSL/
kdesktop/
-libtgvoip/
-lz4/
-rlottie/
-src/
-variant/
-xxHash/
-codegen/
+kotatogram-desktop-*
lib_base/
lib_crl/
lib_lottie/
@@ -17,3 +12,9 @@ lib_rpl/
lib_spellcheck/
lib_tl/
lib_ui/
+libtgvoip/
+lz4/
+rlottie/
+src/
+variant/
+xxHash/
diff --git a/PKGBUILD b/PKGBUILD
index 6de0cf17417c..5db29a4ef7b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,8 +30,10 @@ makedepends=(
optdepends=(
'libnotify: desktop notifications'
)
+conflicts=('kotatogram-desktop-bin' 'telegram-desktop' 'telegram-desktop-bin')
+provides=('kotatogram-desktop')
source=(
- "$pkgname-$pkgver::git+$url.git#tag=k$pkgver"
+ "$pkgname-$pkgver-$pkgrel::git+$url.git#tag=k$pkgver"
"Catch2::git+https://github.com/catchorg/Catch2.git"
"crl::git+https://github.com/telegramdesktop/crl.git"
"GSL::git+https://github.com/Microsoft/GSL.git"
@@ -82,7 +84,7 @@ sha512sums=('SKIP'
prepare() {
- cd "$srcdir/kdesktop"
+ cd "$srcdir/$pkgname-$pkgver-$pkgrel"
git submodule init
git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch2"
@@ -113,7 +115,7 @@ prepare() {
}
build() {
- cd "$srcdir/kdesktop"
+ cd "$srcdir/$pkgname-$pkgver-$pkgrel"
export LANG=en_US.UTF-8
export GYP_DEFINES="DESKTOP_APP_DISABLE_CRASH_REPORTS,TDESKTOP_DISABLE_AUTOUPDATE,TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME,TDESKTOP_DISABLE_DESKTOP_FILE_GENERATION"
export EXTRA_FLAGS="-Winvalid-pch"
@@ -134,17 +136,17 @@ build() {
--depth=Telegram/gyp --generator-output=../.. -Goutput_dir=out Telegram/gyp/Telegram.gyp --format=cmake
NUM=$((`wc -l < out/Release/CMakeLists.txt` - 2))
sed -i "$NUM r ../CMakeLists.inj" out/Release/CMakeLists.txt
- cd "$srcdir/kdesktop/out/Release"
+ cd "$srcdir/$pkgname-$pkgver-$pkgrel/out/Release"
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -UTDESKTOP_OFFICIAL_TARGET
make
}
package() {
install -dm755 "$pkgdir/usr/bin"
- install -m755 "$srcdir/kdesktop/out/Release/Telegram" "$pkgdir/usr/bin/kotatogram-desktop"
+ install -m755 "$srcdir/$pkgname-$pkgver-$pkgrel/out/Release/Telegram" "$pkgdir/usr/bin/kotatogram-desktop"
install -d "$pkgdir/usr/share/applications"
- install -m644 "$srcdir/kdesktop/lib/xdg/kotatogramdesktop.desktop" "$pkgdir/usr/share/applications/kotatogramdesktop.desktop"
+ install -m644 "$srcdir/$pkgname-$pkgver-$pkgrel/lib/xdg/kotatogramdesktop.desktop" "$pkgdir/usr/share/applications/kotatogramdesktop.desktop"
install -d "$pkgdir/usr/share/kservices5"
install -m644 "$srcdir/tg.protocol" "$pkgdir/usr/share/kservices5/tg.protocol"
@@ -154,6 +156,6 @@ package() {
icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
install -d "$icon_dir"
- install -m644 "$srcdir/kdesktop/Telegram/Resources/art/icon${icon_size}.png" "$icon_dir/kotatogram.png"
+ install -m644 "$srcdir/$pkgname-$pkgver-$pkgrel/Telegram/Resources/art/icon${icon_size}.png" "$icon_dir/kotatogram.png"
done
}