summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author3JlOy_PYCCKUI2021-12-19 12:55:18 +0300
committer3JlOy_PYCCKUI2021-12-19 12:55:18 +0300
commitb7a7c7b85965a53cf301c4357d43f2dd3e830b01 (patch)
treeb8a92f15d59cf4aa37b56105a37dc50239d71dc5
downloadaur-b7a7c7b85965a53cf301c4357d43f2dd3e830b01.tar.gz
first commit
-rw-r--r--.SRCINFO54
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2b9d7cbbaf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = kotatogram-desktop-beta-dynamic-bin
+ pkgdesc = Kotatogram – experimental Telegram Desktop fork - Beta version precompiled package
+ pkgver = 1.4.6
+ pkgrel = 1
+ url = https://kotatogram.github.io
+ arch = x86_64
+ license = GPL3
+ depends = hunspell
+ depends = ffmpeg
+ depends = hicolor-icon-theme
+ depends = lz4
+ depends = minizip
+ depends = openal
+ depends = ttf-opensans
+ depends = qt5-imageformats
+ depends = qt5-svg
+ depends = qt5-wayland
+ depends = libdbusmenu-qt5
+ depends = xxhash
+ depends = kwayland
+ depends = glibmm
+ depends = rnnoise
+ depends = pipewire
+ depends = libxtst
+ depends = jemalloc
+ depends = libxrandr
+ depends = abseil-cpp
+ depends = libjpeg-turbo
+ depends = opus
+ depends = openssl
+ depends = libx11
+ depends = libvpx
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = zlib
+ depends = wayland
+ depends = glibc
+ depends = libsigc++
+ depends = glib2
+ depends = xcb-util-keysyms
+ depends = libxcb
+ depends = gcc-libs
+ depends = rlottie-git
+ optdepends = webkit2gtk: embedded browser features
+ optdepends = xdg-desktop-portal: desktop integration
+ provides = kotatogram-desktop
+ conflicts = kotatogram-desktop
+ conflicts = kotatogram-desktop-bin
+ source = https://github.com/3JlOy-PYCCKUi/kotatogram-desktop-betaAUR/releases/download/k1.4.6-1/kotatogram-desktop-beta-1.4.6-1-x86_64.pkg.tar.zst
+ b2sums = a48f50db41aa728bd93fa7570e16df0cd1b5c28a9e001c40b50e29eae7612f43e90fcdcff6bedb1bdc90ae42471246d7e31c7d9178dee960a99391d498b1dbf7
+
+pkgname = kotatogram-desktop-beta-dynamic-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f5b401e3e258
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+kotatogram-desktop-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5756f4d1791
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: 3Jl0y_PYCCKUi <3jl0y_pycckui@riseup.net>
+# Contributor solopasha <daron439 at gmail dot com>
+# Contributor: Ilya Fedin <fedin-ilja2010@ya.ru>
+
+_pkgname=kotatogram-desktop-beta
+pkgname="${_pkgname}-dynamic-bin"
+pkgver=1.4.6
+pkgrel=1
+_pkgrel=1
+pkgdesc="Kotatogram – experimental Telegram Desktop fork - Beta version precompiled package"
+arch=('x86_64')
+url="https://kotatogram.github.io"
+license=('GPL3')
+depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
+ 'qt5-imageformats' 'qt5-svg' 'qt5-wayland' 'libdbusmenu-qt5' 'xxhash' 'kwayland' 'glibmm'
+ 'rnnoise' 'pipewire' 'libxtst' 'jemalloc' 'libxrandr' 'abseil-cpp' 'libjpeg-turbo' 'opus' 'openssl' 'libx11' 'libvpx' 'libxcomposite'
+ 'libxdamage' 'libxext' 'libxfixes' 'zlib' 'wayland' 'glibc' 'libsigc++' 'glib2' 'xcb-util-keysyms' 'libxcb' 'gcc-libs' 'rlottie-git')
+optdepends=(
+ 'webkit2gtk: embedded browser features'
+ 'xdg-desktop-portal: desktop integration'
+)
+conflicts=('kotatogram-desktop' 'kotatogram-desktop-bin')
+provides=('kotatogram-desktop')
+source=("https://github.com/3JlOy-PYCCKUi/kotatogram-desktop-betaAUR/releases/download/k${pkgver}-${_pkgrel}/${_pkgname}-${pkgver}-${_pkgrel}-x86_64.pkg.tar.zst")
+b2sums=('a48f50db41aa728bd93fa7570e16df0cd1b5c28a9e001c40b50e29eae7612f43e90fcdcff6bedb1bdc90ae42471246d7e31c7d9178dee960a99391d498b1dbf7')
+package() {
+ tar -xaf "$srcdir/${_pkgname}-${pkgver}-${_pkgrel}-x86_64.pkg.tar.zst" -C "$pkgdir" --exclude=".*"
+}