summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubin Simons2025-01-11 18:09:50 +0100
committerRubin Simons2025-01-11 18:09:50 +0100
commit2931b53d5fb2f7193723d86f0f42f7a00c3c8e18 (patch)
treea087afb57fc8d5b0f12078b4da42e745ab6b155b
downloadaur-2931b53d5fb2f7193723d86f0f42f7a00c3c8e18.tar.gz
Initial release, v1.3.12
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86f862043602
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kotlin-language-server-bin
+ pkgdesc = Kotlin code completion, diagnostics and more for any editor/IDE using the Language Server Protocol
+ pkgver = 1.3.12
+ pkgrel = 1
+ url = https://github.com/fwcd/kotlin-language-server
+ arch = any
+ license = MIT
+ provides = kotlin-language-server
+ conflicts = kotlin-language-server
+ conflicts = kotlin-language-server-git
+ options = !strip
+ source = kotlin-language-server-1.3.12.zip::https://github.com/fwcd/kotlin-language-server/releases/download/1.3.12/server.zip
+ sha256sums = c3c04f5605948a213721f9ed0760a565beaa5bb982bab807bdf6504f3e824b0d
+
+pkgname = kotlin-language-server-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a955b9b7e2c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Rubin Simons <me@rubin55.org>
+
+_pkgname=kotlin-language-server
+pkgname=${_pkgname}-bin
+pkgver=1.3.12
+pkgrel=1
+pkgdesc="Kotlin code completion, diagnostics and more for any editor/IDE using the Language Server Protocol"
+provides=("kotlin-language-server")
+conflicts=("kotlin-language-server" "kotlin-language-server-git")
+arch=('any')
+url="https://github.com/fwcd/kotlin-language-server"
+license=("MIT")
+
+source=(
+ "${_pkgname}-${pkgver}.zip::https://github.com/fwcd/kotlin-language-server/releases/download/${pkgver}/server.zip"
+)
+
+sha256sums=('c3c04f5605948a213721f9ed0760a565beaa5bb982bab807bdf6504f3e824b0d')
+
+options=("!strip")
+
+package() {
+ install -o root -g root -m 755 -d "${pkgdir}/usr/lib"
+ mv "${srcdir}/server" "${pkgdir}/usr/lib/kotlin-language-server"
+ chmod 644 "${pkgdir}/usr/lib/kotlin-language-server/bin/"*.bat
+ install -o root -g root -m 755 -d "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ ln -s ../lib/kotlin-language-server/bin/kotlin-language-server
+}