summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrim Kriegor2019-06-14 18:45:38 +0100
committerGrim Kriegor2019-06-14 18:45:38 +0100
commiteb9e6d82981ee66936830e55b28ac97c0ff9655e (patch)
treef307cee60f7dc7c680907951e758562b19d09984
downloadaur-eb9e6d82981ee66936830e55b28ac97c0ff9655e.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d4239c5c63a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kotlin-language-server-git
+ pkgdesc = Smart code completion, diagnostics and more for Kotlin using the Language Server Protocol
+ pkgver = 0.1.13.r458.125b3fd
+ pkgrel = 1
+ url = https://github.com/fwcd/KotlinLanguageServer.git
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = java-runtime
+ provides = kotlin-language-server
+ conflicts = kotlin-language-server
+ source = kotlin-language-server::git+https://github.com/fwcd/KotlinLanguageServer.git
+ sha256sums = SKIP
+
+pkgname = kotlin-language-server-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1433df12eb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ricardo Grim Cabrita <grimkriegor@krutt.org>
+
+pkgname=kotlin-language-server-git
+_pkgname=kotlin-language-server
+pkgver=0.1.13.r458.125b3fd
+pkgrel=1
+pkgdesc="Smart code completion, diagnostics and more for Kotlin using the Language Server Protocol"
+arch=(any)
+url="https://github.com/fwcd/KotlinLanguageServer.git"
+license=('MIT')
+conflicts=('kotlin-language-server')
+provides=('kotlin-language-server')
+depends=('java-runtime')
+makedepends=('git')
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s.r%s.%s" \
+ "$(sed -nE 's/^\s*"version": "(.*?)",$/\1/p' package.json)" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./gradlew server:installDist
+}
+
+package() {
+ mkdir -p \
+ "${pkgdir}/usr/share/kotlin" \
+ "${pkgdir}/usr/bin"
+ cp -r \
+ "${srcdir}/${_pkgname}/server/build/install/server/" \
+ "${pkgdir}/usr/share/kotlin/kotlin-language-server"
+ ln -srf \
+ "${pkgdir}/usr/share/kotlin/kotlin-language-server/bin/server" \
+ "${pkgdir}/usr/bin/kotlin-language-server"
+}
+