summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-13 14:57:09 +0200
committerGoliathLabs2020-05-13 14:57:09 +0200
commit1e328e3a99b1514b2829cb593f79024b5fce62b2 (patch)
treec6c2f408f3bd092fc04ece9444d3f9dc1e1553ff
parent4b40a46f64570d71af2e5e90866ef502a3eaf3c4 (diff)
downloadaur-1e328e3a99b1514b2829cb593f79024b5fce62b2.tar.gz
Updated: 1.4.0-dev-8404
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ec0398bf0a8..a1dd50b45796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kotlin-native
pkgdesc = A LLVM backend for the Kotlin compiler
- pkgver = 1.2.0
+ pkgver = 1.4.0dev8404
pkgrel = 1
url = https://github.com/JetBrains/kotlin-native
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = kotlin-native
options = staticlibs
options = libtool
options = !strip
- source = kotlin-native-1.2.0::https://github.com/JetBrains/kotlin-native/archive/v1.2.0.tar.gz
- sha512sums = 165f0aab2b60063cfd331991e5b353a0f47a4bb724929b593216aa4e72eeac1050f77a61c7e3d160502c3ff0c37fd941632d45a3833d7983265bf30deab97b61
+ source = https://github.com/JetBrains/kotlin-native/archive/build-1.4.0-dev-8404.tar.gz
+ sha512sums = 88eca274f6800029453505ce185bf5068cca69536c6de7b51a8219934b3be76fbfb1f44e812dc78a4c58958d33b47fceb0fac1f3abf17f856d444868d723f33d
pkgname = kotlin-native
diff --git a/PKGBUILD b/PKGBUILD
index b8e3f0fdce15..1c7a91356994 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
-# Maintainer: Philippe Hürlimann <p@hurlimann.org>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Philippe Hürlimann <p@hurlimann.org>
pkgname=kotlin-native
-pkgver=1.2.0
+_pkgname=kotlin-native-build
+pkgver=1.4.0dev8404
+_pkgver=1.4.0-dev-8404
pkgrel=1
pkgdesc="A LLVM backend for the Kotlin compiler"
arch=('x86_64')
@@ -8,23 +11,23 @@ url="https://github.com/JetBrains/kotlin-native"
license=('Apache')
options=('staticlibs' 'libtool' '!strip')
depends=('java-environment' 'ncurses5-compat-libs')
-source=(${pkgname}-${pkgver}::https://github.com/JetBrains/kotlin-native/archive/v${pkgver}.tar.gz)
-sha512sums=('165f0aab2b60063cfd331991e5b353a0f47a4bb724929b593216aa4e72eeac1050f77a61c7e3d160502c3ff0c37fd941632d45a3833d7983265bf30deab97b61')
+source=(https://github.com/JetBrains/kotlin-native/archive/build-${_pkgver}.tar.gz)
+sha512sums=('88eca274f6800029453505ce185bf5068cca69536c6de7b51a8219934b3be76fbfb1f44e812dc78a4c58958d33b47fceb0fac1f3abf17f856d444868d723f33d')
prepare() {
- cd ${pkgname}-${pkgver}
+ cd ${srcdir}/${_pkgname}-${_pkgver}
./gradlew dependencies:update
}
build() {
- cd ${pkgname}-${pkgver}
+ cd ${srcdir}/${_pkgname}-${_pkgver}
./gradlew dist
}
package() {
mkdir -p ${pkgdir}/opt
mkdir -p ${pkgdir}/usr/bin
- cp -R ${pkgname}-${pkgver}/dist ${pkgdir}/opt/kotlin-native
+ cp -R ${_pkgname}-${_pkgver}/dist ${pkgdir}/opt/kotlin-native
chmod 755 ${pkgdir}/opt/kotlin-native
ln -s /opt/kotlin-native/bin/kotlinc-native ${pkgdir}/usr/bin/kotlinc-native
ln -s /opt/kotlin-native/bin/konanc ${pkgdir}/usr/bin/konanc