summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2018-06-27 17:34:01 +0800
committerKaizhao Zhang2018-06-27 17:34:01 +0800
commit5b51c46b8dfd5645927eadeec1bd602d71b5b20a (patch)
tree3685ecc9ed065b655dbb3bd0ee44042f5ca4296d
parent73fe14a31d9c000a9a132ca69d0ca80804465413 (diff)
downloadaur-5b51c46b8dfd5645927eadeec1bd602d71b5b20a.tar.gz
Update to version 0.7.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fe0713777fe..255916a1e071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kotlin-native-bin
pkgdesc = A LLVM backend for the Kotlin compiler
- pkgver = 0.7
+ pkgver = 0.7.1
pkgrel = 1
url = https://github.com/JetBrains/kotlin-native
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = kotlin-native-bin
options = staticlibs
options = libtool
options = !strip
- source = https://github.com/JetBrains/kotlin-native/releases/download/v0.7/kotlin-native-linux-0.7.tar.gz
- sha512sums = b78b14e71b426effd8b62aad89535cf364284174bbb54a05d186478a23e92405f89336e98be6e83793cad61b9577e34ff26ae8c592b5c9eba04ded0f28b6a9d3
+ source = https://github.com/JetBrains/kotlin-native/releases/download/v0.7.1/kotlin-native-linux-0.7.1.tar.gz
+ sha256sums = a0ba4d2bb6d9035c6576383cc8d96e25eb33bc8876c299715fb7e1ca401cbe3b
pkgname = kotlin-native-bin
diff --git a/PKGBUILD b/PKGBUILD
index cf5672cf85ec..211bb2435b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+PKGEXT=.pkg.tar
+
pkgname=kotlin-native-bin
-pkgver=0.7
+pkgver=0.7.1
pkgrel=1
pkgdesc="A LLVM backend for the Kotlin compiler"
arch=('x86_64')
@@ -12,7 +14,7 @@ depends=('java-environment' 'ncurses5-compat-libs')
provides=('kotlin-native')
conflicts=('kotlin-native' 'kotlin-native-git')
source=("https://github.com/JetBrains/kotlin-native/releases/download/v${pkgver}/kotlin-native-linux-${pkgver}.tar.gz")
-sha512sums=('b78b14e71b426effd8b62aad89535cf364284174bbb54a05d186478a23e92405f89336e98be6e83793cad61b9577e34ff26ae8c592b5c9eba04ded0f28b6a9d3')
+sha256sums=('a0ba4d2bb6d9035c6576383cc8d96e25eb33bc8876c299715fb7e1ca401cbe3b')
package() {
install -d "${pkgdir}/usr/bin"