summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2018-04-11 16:06:43 +0800
committerKaizhao Zhang2018-04-11 16:06:43 +0800
commit9ab021848acbeda35a7bb53d7cdcacb402837de7 (patch)
treea75e7c09796f6f47c1a6dd19f890de6ecde1dfd4
downloadaur-9ab021848acbeda35a7bb53d7cdcacb402837de7.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD30
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..622041eccc7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kotlin-native-bin
+ pkgdesc = A LLVM backend for the Kotlin compiler
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/JetBrains/kotlin-native
+ arch = x86_64
+ license = Apache
+ depends = java-environment
+ depends = ncurses5-compat-libs
+ provides = kotlin-native
+ conflicts = kotlin-native
+ conflicts = kotlin-native-git
+ options = staticlibs
+ options = libtool
+ options = !strip
+ source = https://github.com/JetBrains/kotlin-native/releases/download/0.6.2/kotlin-native-linux-0.6.2.tar.gz
+ sha512sums = 4600216116e9480550ada878b4365b4e391c4d355964e19e2e3011a92ba5afe2bb1844691c3ecb730b1d1d8d299c668a22cec0cacdf4d6b8712fe1d6c079a929
+
+pkgname = kotlin-native-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f28920d34e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+pkgname=kotlin-native-bin
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="A LLVM backend for the Kotlin compiler"
+arch=('x86_64')
+url="https://github.com/JetBrains/kotlin-native"
+license=('Apache')
+options=('staticlibs' 'libtool' '!strip')
+depends=('java-environment' 'ncurses5-compat-libs')
+provides=('kotlin-native')
+conflicts=('kotlin-native' 'kotlin-native-git')
+source=("https://github.com/JetBrains/kotlin-native/releases/download/${pkgver}/kotlin-native-linux-${pkgver}.tar.gz")
+sha512sums=('4600216116e9480550ada878b4365b4e391c4d355964e19e2e3011a92ba5afe2bb1844691c3ecb730b1d1d8d299c668a22cec0cacdf4d6b8712fe1d6c079a929')
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/lib"
+
+ cp -r kotlin-native-linux-${pkgver} ${pkgdir}/usr/lib/kotlin-native
+ chmod 755 ${pkgdir}/usr/lib/kotlin-native
+
+ ln -s /usr/lib/kotlin-native/bin/kotlinc-native ${pkgdir}/usr/bin/kotlinc-native
+ ln -s /usr/lib/kotlin-native/bin/konanc ${pkgdir}/usr/bin/konanc
+ ln -s /usr/lib/kotlin-native/bin/klib ${pkgdir}/usr/bin/klib
+ ln -s /usr/lib/kotlin-native/bin/cinterop ${pkgdir}/usr/bin/cinterop
+ ln -s /usr/lib/kotlin-native/bin/jsinterop ${pkgdir}/usr/bin/jsinterop
+ ln -s /usr/lib/kotlin-native/bin/run_konan ${pkgdir}/usr/bin/run_konan
+}