summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Kauffman2017-04-04 14:33:33 -0400
committerKyle Kauffman2017-04-04 14:36:57 -0400
commitaf71f179135402f7b3adfa9a976298db1fe613e4 (patch)
tree4be07ab78962f16756b95f6c9f510ea7e841b8da
downloadaur-af71f179135402f7b3adfa9a976298db1fe613e4.tar.gz
Initial package of kotlin-native from git.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b690a8f259df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kotlin-native-git
+ pkgdesc = A LLVM backend for the Kotlin compiler
+ pkgver = r2055.305dbd30
+ pkgrel = 1
+ url = https://github.com/JetBrains/kotlin-native
+ arch = x86_64
+ license = Apache
+ depends = java-environment
+ depends = ncurses5-compat-libs
+ options = staticlibs
+ options = libtool
+ options = !strip
+ source = git+https://github.com/JetBrains/kotlin-native.git
+ sha512sums = SKIP
+
+pkgname = kotlin-native-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..298dd9bfc3fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+plainname=kotlin-native
+pkgname="$plainname-git"
+pkgver=r2055.305dbd30
+pkgrel=1
+pkgdesc="A LLVM backend for the Kotlin compiler"
+arch=('x86_64')
+url="https://github.com/JetBrains/kotlin-native"
+license=('Apache')
+options=('staticlibs' 'libtool' '!strip')
+depends=('java-environment' 'ncurses5-compat-libs')
+source=("git+https://github.com/JetBrains/kotlin-native.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$plainname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $plainname
+ ./gradlew dependencies:update
+}
+
+build() {
+ cd $plainname
+ ./gradlew dist
+}
+
+package() {
+ mkdir -p ${pkgdir}/opt
+ mkdir -p ${pkgdir}/usr/bin
+ cp -R ${plainname}/dist ${pkgdir}/opt/kotlin-native
+ chmod 755 ${pkgdir}/opt/kotlin-native
+ ln -s /opt/kotlin-native/bin/kotlinc-native ${pkgdir}/usr/bin/kotlinc-native
+ ln -s /opt/kotlin-native/bin/konanc ${pkgdir}/usr/bin/konanc
+ ln -s /opt/kotlin-native/bin/cinterop ${pkgdir}/usr/bin/cinterop
+}