summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGyo2011-02-05 23:13:21 -0800
committerMarkus Heidelberg2015-06-26 23:20:58 +0200
commit1a248a1123f8bb476c580aedd1f3e7dc380f4095 (patch)
treefcc27ccbcc9dc95c74bd283b1ad1100e3da203df
downloadaur-1a248a1123f8bb476c580aedd1f3e7dc380f4095.tar.gz
koules 1.4-2: initial import
** Manually imported from AUR 3 **
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--koules-1.4-gcc3.patch.bz2bin0 -> 5635 bytes
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1cb398fb251
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = koules
+ pkgdesc = A fast arcade game based on fundamental law of bodies attraction
+ pkgver = 1.4
+ pkgrel = 2
+ url = http://www.ucw.cz/~hubicka/koules/English/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = patch
+ makedepends = imake
+ makedepends = xextproto
+ makedepends = xproto
+ depends = dialog
+ depends = libx11
+ depends = libxext
+ source = http://www.ucw.cz/~hubicka/koules/packages/koules1.4-src.tar.gz
+ source = koules-1.4-gcc3.patch.bz2
+ md5sums = 0a5ac9e57c8b72e9fc200bc98273235c
+ md5sums = b16677698a084e11e78324098b7a9e57
+
+pkgname = koules
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05af7c3d73b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Gyo <nucleogeek_at_gmail_dot_com>
+pkgname=koules
+pkgver=1.4
+pkgrel=2
+pkgdesc="A fast arcade game based on fundamental law of bodies attraction"
+arch=('i686' 'x86_64')
+url="http://www.ucw.cz/~hubicka/koules/English/"
+license=('GPL')
+depends=('dialog' 'libx11' 'libxext')
+makedepends=('patch' 'imake' 'xextproto' 'xproto')
+source=(http://www.ucw.cz/~hubicka/koules/packages/${pkgname}${pkgver}-src.tar.gz $pkgname-$pkgver-gcc3.patch.bz2)
+md5sums=('0a5ac9e57c8b72e9fc200bc98273235c' 'b16677698a084e11e78324098b7a9e57')
+
+build() {
+ # some sources modifications
+ cd $startdir/src/${pkgname}${pkgver}
+ patch -Np1 < ../$pkgname-$pkgver-gcc3.patch || return 1
+ sed -i \
+ -e "/^KOULESDIR/s:=.*:=/usr/bin:" \
+ -e "/^SOUNDDIR/s:=.*:=/usr/share/$pkgname:" Iconfig || return 1
+ sed -i \
+ -e "s:/usr/local/bin:/usr/bin:" koules || return 1
+ sed -i \
+ -e 's:exec.*tcl:exec xkoules -M "$@":' koules || return 1
+
+ ln -s xkoules.6 xkoules.man
+ ln -s xkoules.6 xkoules._man
+
+ # generate makefiles and building
+ xmkmf -a
+ sed -i \
+ -e '/SYSDEFS =/d' \
+ -e "/^ *CFLAGS =/s:$: ${CFLAGS}:" Makefile || return 1
+ make || return 1
+
+ # installation
+ mkdir -p $startdir/pkg/usr/bin
+ install -m755 xkoules $startdir/pkg/usr/bin
+ install -m755 koules $startdir/pkg/usr/bin
+ mkdir -p $startdir/pkg/usr/share/koules
+ install -m755 koules.sndsrv.linux $startdir/pkg/usr/share/koules
+ install -m644 sounds/* $startdir/pkg/usr/share/koules
+ mkdir -p $startdir/pkg/usr/share/man/man6
+ install -m644 xkoules.6 $startdir/pkg/usr/share/man/man6
+}
diff --git a/koules-1.4-gcc3.patch.bz2 b/koules-1.4-gcc3.patch.bz2
new file mode 100644
index 000000000000..a01b9eef8759
--- /dev/null
+++ b/koules-1.4-gcc3.patch.bz2
Binary files differ